Go Down

Topic: Can only burn bootloader once (Read 163 times) previous topic - next topic


I  have a board with an ATMega1284p with just the 6 connections to the ICSP connector (currently for testing).  There are decoupling caps on the ATMga1284p and a pull-up on reset.

I can only burn a bootloader once.  I have tried Arduino as an ISP and USBasp for programmers.  I can burn a chip fine just once but subsequent tries it fails.   

MISO seems stuck low after burning the bootloader.  So the programmer can't read MISO.

Is there a ATMega pin I'm missing?


The most common cause of this symptom is setting the fuses for an external clock source when there is no external clock. That "bricks" your chip until you connect a clock to get the processor running again.

Is the board definition you have selected in the Arduino IDE configured to use an external clock, or the internal oscillator? If the former, do you have a clock source (e.g., crystal) connected? If the latter, what is the clock speed?


That was it - problem solved 

Go Up