So just call it muDebounce() ?99% of Arduino folks will not be starting from a knowledge of PLCs so compatibility is irrelevant and the transfer of understanding even less relevant.In my mind functions should have simple and obvious names so that the user does not have to scratch his head (or check the manual) to remember what they are for or how to use them. Also "obvious" should mean "obvious in the context of the user's existing knowledge" (not the programmers existing knowledge).
That may mean having more functions in a library, several of which may use near-identical code. Or perhaps one function would call another after adding some parameter so the user would not have to.
Noted.Best wishes with the project.
PS:It looks as such a library is like an anthill, there is always something to do, to improve or extend it.
The instructions are here:https://github.com/arduino/Arduino/wiki/Library-Manager-FAQPlease let me know if you have any questions.