Go Down

Topic: Clocks and LoraWAN (Read 46 times) previous topic - next topic

mattb1969

Hi,

I have recently posted how I had configured the mkrwan to have a rtc, wdt and edge based interrupts.

I have OSCULP32K routed via GCLK1 (divide 4)  to WDT, RTC and EIC and the processor configured into deep sleep until the RTC wakes it back up.

However, now that I have also wired in the LoraWAN stuff, it is unable to connect, model.begin(EU868) fails. I have tried various things, different combinations of code order to see if I can get it to work, but I am not having any success. I have had a read through the mkrwan.h and associated files and I can't seem to find anything that gives an sign posts to the cause.

I think this because, if I run in full power, it works, the only bit of code that is different is shown below:
Code: [Select]
if TESTMODE {
    DEBUG = true;
    Serial.begin(115200);
    if (!Serial) delayMicroseconds(2500*1000);
}
else {
    DEBUG = false;
    USBDevice.detatch();
}

So I think it is to do with the serial comms, but I can't figure out what it can be. Serial.begin(115200) is to enable the serial monitor, nothing more, or at least I think that is the case.
Any ideas?

Go Up