Go Down

Topic: cant upload codes from computer to arduino (Read 891 times) previous topic - next topic


I just got my first arduino today, it is the mega 2560, it was a kit that came pre-loaded to to do random things on a 128x64 lcd display. I wanted to do something else though so i took everything off and made a 12 LED dimmer thing. After selecting the board and serial port from the tools menu in the programming software and verifying the code i uploaded it, everything seemed to be going okay 'till i got an error message:

avrdude: stk500v2_command () : unknown stus 0xc8
avrdude: initialization failed, rc=-1
               Double check connections and try again, or use -F to
               This check.

avrdude: stk500v2_command () : unknown status 0x01
avrdude: stk500v2_disable () : failed to leave programming mode

I get that message no matter what code i try to use. i tried uploading it with the board unplugged and got the same message so it seems like it thinks theres a bad connection but the power comes on when it's plugged in.

Coding Badly

Oct 23, 2011, 08:27 am Last Edit: Oct 23, 2011, 09:07 am by Coding Badly Reason: 1

Does this help?


Same problem, with an Arduino 2560 ADK, Nothing attached and with The sample program Bling. Com3 is Regognized as an Arduino 2560 and said to be working fine (Windows Vista, Ide 022)


Ok, so I solved it myself. After testing the board on an old XP it worked, reinstalling the drivers in Vista didn't work, but forcing (in vista systems) the board to go from Com:3 to Com:6 did the trick. Why???

Go Up