Go Down

Topic: Windows/Linux/Mac Eclipse plugin to compile and upload arduino sketches (Read 407312 times) previous topic - next topic

Headroom

I do have a paypal account and a donations page. http://www.eclipse.baeyens.it/donate.html


Jantje
I'd like to add to that I f you regularly work with the Arduino Eclipse IDE/plugin please donate. I wrote installation instructions and posted them on my blog http://trippylighting.com/teensy-arduino-ect/arduino-eclipse-plugin/arduino-eclipse-ide-and-plugin-v2-2-installation/ about a year ago and
based on post hits I'd assume there are hundreds of users by now that regularly use this plugin. Based on another conversation that I had with Jantje a while ago my estimate would be that 90% percent of users do not donate at all.
That indicates that there are a lot of people that gladly take from the open source community but are not willing to provide anything. If you have a paypal account, please use it ;-)
While open source is usually free for the user it never is free for the developer!!!
http://trippylighting.com

http://ledshield.wordpress.com/

SK-Arduino

Hi,
i just downloaded the win64.2014-10-30_02-06-03 release. Unfortunately stuff like OUTPUT, pinMode(), etc. doesn't get recognized by Eclipse so it looks like the following:

Rebuilding the Index doesn't help either. Building/Compiling works fine without any errors though. I'm using Java 1.8.0_20 and Win 7.

Thanks for your help,

Stefan

delateurj

Hi,

Is there a way to disable the verification step? I unchecked that option in the Arduino IDE that the plug in is pointing to but that did not seem to have any effect.

Thanks,
Joe.

rlogiacco

What verification step are you referring to? I usually build my sketch and then upload to the board... if you want to execute the two with one click only then I believe Jantje and his team would be happy to increase the priority of such feature if you would express your interest into the plugin with a little donation... :-)
Please, do not send me personal messages containing forum related questions: I will not answer.

I share my discoveries and thoughts at http://rlogiacco.wordpress.com

delateurj

Hi,

Thanks for the clarifying question.  I am referring to the verification step in the upload process where the code is read after writing and verified.  Happy to donate more to bump on a list of feature requests.

Regards,
Joe.

rlogiacco

Ahh, I got you! Well, I know that almost doubles the upload time, I didn't ever thought about disabling it, but I guess it might speed up the process sensibly with big firmwares
Please, do not send me personal messages containing forum related questions: I will not answer.

I share my discoveries and thoughts at http://rlogiacco.wordpress.com

Jantje

Seems I'm no longer informed messages get added here  :o
@delateurj
As far as I understand your question: the behaviour you ask for is the only supported behaviour in the plugin right now.
The build before upload feature (which is the default arduino behaviour) is on the todo list.

@SK-Arduino
You have not specified your arduino IDE version. Assuming it is >1.5.6: This is indeed the behaviour on windows due to a change in the arduino delivered toolchain. See this issue https://github.com/arduino/Arduino/issues/2422


@Headroom
Thanks, and well said

Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

jaruj9

Hello Guys, I am one of the satisfied user of this eclipse plugin. I am really happy you made it!

Well not completely satisfied, when I do not count, that on widows I am not able to build projects with v2.2 and arduino >1.5.6 what i read, that on windows there are still some bugs.
What bothers me more is, that on Linux mint 17 kernel:3.13.0-24-generic I can compile my project with 1.5.8 IDE but I can not upload it to arduino UNO or DUE. Error which I get is:

"No device on /dev/ttyACM0"

I chosen right tools/board and  tools/port I marked exactly this port but still does not work.

I would really like if you will give me some advice how to resolve it. I goggled a lot and I found some Solutions but non of those worked. Please some working fix!

Thank YOU!!!

Jantje

Hi jaruj9
I'm using redhat enterprise edition as OS which is also a Linux.
There used to be a problem in linux http://eclipse.baeyens.it/Arduino%20eclipse%20plugin%20FAQ.html#LinuxNoSerialPorts but that was fixed a long time ago.
The DUE is a bit of a problem as I never got it to work on my system (not even with the Arduino IDE; the port is never recognized) but the uno works fine here and I know it works fine on any other linux systems.

As you may know we moved away from rxtx to someting new which is only in the nightly build for now.
Can you upgrade to the nightly and see wether that works?
Here is a link on how to upgrade http://eclipse.baeyens.it/rlogiacco/how_to.shtml

Please let us know how it worked.
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

rockwallaby

jaruj9, with your error;
Quote
"No device on /dev/ttyACM0"
can you go into your command line, say in terminal and list your devices by typing;
Code: [Select]
ls /dev
to check if ttyACM0 does in fact exist?

If the operating system doesn't list the port, then it will fail to upload.

Unplug the cable to the Arduino, wait 5 seconds, plug it back in and do that command again and see if you can see it or any other new tty port since you pluged it back in.

Yes, this plugin by Jantje is wonderful, I wouldn't use Arduino's now if I wasn't able to use the Eclipse IDE.
____
Paul
Paul - VK7KPA

jaruj9

Thank you for all of your responses!! I am really happy for it.

@jatje I will have to stay on linux mint becuase I habe there already lot of stuff installed which are payed and I need exactly this one for my university.  I still did not have time to try my uno. But Teensy with hacket ide 1.5.8 works great I can update and upload my projects to teensy 3.1. But with due is not possible. I updated eclipse ide to 2.4 what I guess is the latest possible.

I reallysed that i can not upload project to due even in arduino ide as you said. SO probably there will be general problem in linux + due or?

@rockwallaby
Yes it it is seeable also in lsusb, maybe it can be someting with rules as teensy has that necessary?

Thank you so much guys for help!

jaruj9

UPDATE: after changing bound rate before uploading file on comport /dev/ttyACM0 to 1200 (automatically is 115200) I managed upload my project to arduino due but just ONCE what is kind of bad and good. Do you have some more ides?

Do you think it can be something with due hardware? Like here describes http://forum.arduino.cc/index.php?topic=167492.0 .

I am sure somebody already have done it. Nobody had similar problem?

I tried this tutorial here but on the part setting udev(for due) and setting permissions I have troubles. I do not understand it really properly + what i did, did not work for me. Maybe do you have some better explanation?
http://playground.arduino.cc/Linux/All

Juraj

Jantje

Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

jaruj9

Ok sorry, I explained it wrong, so let me start again.

Actual configuration:  I am running Linux mint 17 with kernel: 3.13.0
I have  arduino IDE 1.5.8, teensyduino 1.20 and eclipseArduino v2.4. I added to arduino IDE 1.5.8 all necessary files to make it work for teensy. following this tutorial:

http://trippylighting.com/teensy-arduino-ect/arduino-eclipse-plugin/installation-of-the-arduino-eclipse-ide-teensyduino-win-7/


my actual state with  TEENSY: I am able compile and upload my projects in eclipseArduino to teensy with teensybootloader - works as it should. What does not work, is compile project in arduino IDE. It returns following error:

Arduino: 1.5.8 (Linux), Board: "Teensy 3.1, Serial, 96 MHz (overclock), US English"

Cannot run program "/opt/arduino-1.5.8/hardware/teensy/teensy/tools/linux/arm-none-eabi/bin/arm-none-eabi-g++": error=2, No such file or directory

As this error says it  searches a file /teensy/teensy which,ofc, does not exists! I tried already some combinations where to save /teensy folder, but I never reached  successful compilation. I have to say this error does not bothers me, because I will never use Arduino IDE for developing. I will always use eclipseArduino which works correctly. I am giving you just information that it does not work.

my actual state with  ARDUINO DUE:

I can not upload project to arduino due(eclipseArduino arduino IDE), it writes error:
No device found on ttyACM0

I followed this tutorial: http://forum.arduino.cc/index.php?topic=148613.0
where they explain that before uploading to arduino due you have to set bound-rate to 1200 with following command:
stty -F /dev/ttyACM0 speed 1200 cs8 -cstopb -parenb

After using this command, I am able to upload ONCE my project but after,even I run again this command in terminal, I get always error No device found on ttyACM0

after executing commang ls /dev/tty* in terminal, I see that Linux see arduino due on port /dev/ttyACM0. Even lsusb sees my DUE:
Bus 003 Device 011: ID 2341:003d Arduino SA

I tryed to follows this tutorial :
http://playground.arduino.cc/Linux/All

I did not move with this error. I am not sure if I sated permissions correctly.


I hope after this explanation you will have more Ideas where is the problem on DUE + linux


Jantje

This makes more sense to me. Thanks for that.
I think you have 2 problems:
Problem 1: Teensy not working in Arduino IDE.
No one ever said that should or could work, it simply doesn't, it never has.

Problem 2:Due not uploading.
If I understood correctly it doesn't upload in the Arduino IDE and it doesn't upload in arduino eclipse plugin.
As it does not work in the Arduino IDE it won't work in the Arduino eclipse plugin.
The plugin doesn't work on my system
So basically you're posting in the wrong location for this problem.

I'm sorry I can't help you out here.

Best regards
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Go Up