Go Down

Topic: Having trouble flashing some ATmega644s (Read 544 times) previous topic - next topic

Tchnclfl

Feb 23, 2010, 01:04 am Last Edit: Feb 23, 2010, 01:11 am by Tchnclfl Reason: 1
Let me start off by saying this is the ATmega644-20PU (and NOT the 644P).

I've successfully used Arduino as ISP to burn bootloaders to '328 chips, and now I'm trying it with some 644s.

When I try it, I get the "YIKES!  Invalid device signature!" error from AVRdude.  As I didn't have any 16MHz oscillators on hand, I was rigging another arduino's crystal (through the chip socket) to the fresh 644.

I'm hoping the error is because of the long (4-6 inch) wires I'm using to connect the crystal, which is causing problems.  Could that cause this problem?  Is it likely?  If so, I'll just have to wait for my digikey shipment to get here to flash these things.. :P

By the way, I also get the same error without any crystal, making me think more that it is an interference problem.

Osgeld

#1
Feb 23, 2010, 01:48 am Last Edit: Feb 23, 2010, 01:48 am by Osgeld Reason: 1
Quote
I'm hoping the error is because of the long (4-6 inch) wires I'm using to connect the crystal, which is causing problems.  Could that cause this problem?


it could cause problems, yes, pull the 16mhz resonator off of your really bare bones (and put a female header in its place) and try it as close to the 644 as you can
http://arduino.cc/forum/index.php?action=unread;boards=2,3,4,5,67,6,7,8,9,10,11,66,12,13,15,14,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,86,87,89,1;ALL

Tchnclfl

Alright.  The problem is that the resonator has 3 pins (and it's hard to mount the 3-pin resonator in a two pin spot, especially when the two pins needed aren't adjacent), so what would you recommend?  Think I should bend the pins a lot to get it to fit, and then attach ground to the middle ones?

Osgeld

try tacking on some resistor leads if you have steady hands, aside from that it depends if you can live longer with your RBBB working, or seeing if this solves your problem

http://arduino.cc/forum/index.php?action=unread;boards=2,3,4,5,67,6,7,8,9,10,11,66,12,13,15,14,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,86,87,89,1;ALL

Go Up