Go Down

Topic: Traxxas E-revo robot projekt (remove failsafe?) (Read 2281 times) previous topic - next topic

Evilswede

Hello!

I'm working on a robotic project in school and i have a small problem that i need to solve before i can even start.
When i remove the cable from the receiver on the car and plugs the cable in to my Arduino board that i'm using to program the software the fail safe kicks in and prevents the ESC to work properly.
Im using the Black and the white wire from the ESC to controll the ESC through the Arduino but i think i should use the red wire aswell but how should i connect it so the Fail safe won't start.

Sorry for bad english!

JasonK

You probably don't want to remove the failsafe as it is a failsafe, instead you should figure out what is triggering it.

lets start with some questions to see if we can gather the needed information to assist:

1) what is the code you are running on the arduino?

2) Please supply a link to a specification sheet for the Electronic Speed Controller you are using so we can compare your code to the specs.

Evilswede

Thanks for your help!

1) I'm using the servo libary to "try" controlling the ESC.

2) In the E-Revo 1:16 is a Traxxas XL-2.5 ESC
http://traxxas.com/products/parts/escs/xl25

trying as we speak find more detailed specification sheet for the ESC

JasonK

is this what is happening: http://traxxas.com/support/Traxxas-Speed-Controls-and-Low-Voltage-Detection-LVD

Evilswede

That seems like the problem, ill try that and report back if the problem is solved :)

Evilswede

It can't be that Low voltage detection thing, because my ESC doesnt have that :/
so the problem is unsolved still :/

Go Up