Go Down

Topic: Transfert librairie sous Arduino 1.0 (Read 3077 times) previous topic - next topic

Bubule

Bonjour

Je viens de télécharger la version 1.0, et ai aussitôt tenté de compiler mon ancien programme.
La librairie PID n'est pas reconnue.
J'ai donc copié la librairie dans le répertoire "libraries" de la nouvelle version. J'ai fermé et rouvert l'application. Bien qu'elle apparaisse dans le menue librairie, elle n'est toujours pas reconnue lors de la compilation.
Une idée ?

Franck

skywodd

Bonjour,

Avec le passage en version 1.0 l'ide arduino a subit énormément de changements, certain très radicale, les sketchs arduino n'ont plus l'extension .pde mais .ino et les librairies arduino devront désormais utiliser Arduino.h au lieu de WProgram.h, ce qui signifie que telle quelle, plus aucune librairie arduino n'est en mesure d'être compiler sous arduino 1.0 .

J'ai cependant réglé temporairement ce probléme en copiant le fichier Arduino.h situé dans ../hardware/arduino/core/arduino sous le nom de WProgram.h, ainsi les librairies pour arduino 0022 continu de compiler en plus des librairies 1.0 .

Mais ceci est temporaire ... un jour ou l'autre il faudra bien rendre les librairies existante compatible arduino 1.0 car il y a eu pas mal de changement mais cela va prendre énormément de temps et un grand nombre de librairie resteront à l'abandon ...
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

Bubule

Bonjour,

SUPER !
Sans trop chercher à comprendre pourquoi (çà me dépasse !)
Ça fonctionne impeccable ainsi  :)

Merci Skywood

Bon dimanche

Franck

bilyboy

Merci Skywood, je commençais à en avoir marre et ta réponse m'a "sauvé".

AlienArea51

Salut Messieurs
On parlai justement de la version 1.0 sur le Topic que vous savez   XD XD
@+
The truth is elsewhere !!

Go Up