Go Down

Topic: Programmer is not responding problem after attempting to bootload atmega 328 (Read 1 time) previous topic - next topic

tnflyboy

I recently attempted to load the arduino bootloader on to an atmega328 chip that I recently purchased, following these instructions:
http://arduino.cc/en/Tutorial/ArduinoToBreadboard

After completing the instructions, my Uno would no longer work properly and the chip that I attempted to bootload would not work either. Every time I attempted to load a sketch on to the Uno I got the following message:

Code: [Select]
avrdude: stk500_recv(): programmer is not responding

I have performed the suggested troubleshooting steps on the arduino guide page and performed the loop-back test (it worked). Here are my specs:


  • Your operating system.
    Mac OSX 10.7.2

  • What kind of board you have.
    Arduino Uno

  • Whether or not you were ever able to upload to the board. If so, what were you doing with the board before / when it stopped working, and what software have you recently added or removed from your computer?
    Yes, I have been able to upload to the board previously. For other comments, see above.

  • The messages displayed when you try to upload with verbose output enabled. To do this, hold down the shift key while clicking on the upload button in the toolbar.
    See code above




Bp103

You could maybe try the Parallel Programmer then burn the bootloader onto the chip while its still in the arduino.
http://arduino.cc/en/Hacking/ParallelProgrammer

I don't know much about mac but this is what i used to make avrdude write the bootloader to it. (The ide failed to do it for some reason)

Its a bat file for windows but I think you'll get it.
Code: [Select]
set bootloader=C:\arduino-1.0\hardware\arduino\bootloaders\optiboot\optiboot_atmega328-Mini.hex
rem   Bootloader path

set avrdude_path=C:\arduino-1.0\hardware/tools/avr/bin/
rem   Path to avrdude

set avrdude_conf=C:\arduino-1.0\hardware/tools/avr/etc/avrdude.conf
rem   path to avrdude.conf

%avrdude_path%avrdude -C%avrdude_conf% -v -v -v -v -patmega328p -cdapa -F -Uflash:w:%bootloader%:i


btw everything encased in %'s are strings replace them as needed.

tnflyboy

Bp thanks for the info, I unfortunately don't have a parallel connector or a port on my computer. I think it'd probably be easier for me to buy another 328 with the bootloader already on it.

Jim, I don't have the auto-reset still disabled.

More info... Here's what comes up when I try to upload Blink to the board.

Code: [Select]
avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/tnflyboy/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/tty.usbmodem411
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.


Any other ideas from anyone? I can't really be the first person with this problem.  :)

smeezekitty

USB to parallel adapters are fairly cheap and then you would have it for the future.
Avoid throwing electronics out as you or someone else might need them for parts or use.
Solid state rectifiers are the only REAL rectifiers.
Resistors for LEDS!

tnflyboy

update:

I replaced the atmega328 on my uno with an atmega328 chip with bootloader already installed on it from sparkfun. Attempting to upload the blink program to the board produces the same error. Is my uno shot, or is there anything else I can do?

tnflyboy

Ok, it's working now. Rather than delete this post because I realized I'm an idiot, I'll keep it up, just in case someone has a similar problem... Turns out the chip was put in backwards. Again, I'm an idiot.

CrossRoads

Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

tnflyboy

Didn't really notice, I was never able to get a program loaded for obvious reasons, so I didn't keep it running too long.

Go Up