Go Down

Topic: Upload Timeout Error on Mega 2560 - Not Sure What Changed (Read 284970 times) previous topic - next topic

KostasF

Hello everyone i am new member at this open mind and open source community i use SainSmart (atmega2560) for my thesis about a field controller .....
I have the same error !!!( I took 3 days of my life )

1) I try to dfu-program my atmega16u2 ( 8 bit Avr controller ) witch Arduino Mega and i think also Uno R3 use for USB but nothing

2) I follow this schema  for  making an AVR ISP to re-burn bootloader  but also nothing for my upload ,i take timeout.error()
https://scontent-b-cdg.xx.fbcdn.net/hphotos-frc3/t1.0-9/1947727_10203357193275789_1149508726_n.jpg

3) The only solution is to reborn my old AMD 3200+ and use the Parallel Port for boot-loader , install Linux Mint  over this PC ( Mate better for it's 512mb ram ) follow this instructions
http://arduino.cc/en/Hacking/ParallelProgrammer#.UytVHXWSxBt
open Arduino IDE as Super User select my board and parallel port as programmer and after 2 minutes voila new boot-loader over my Atmega ....
Re plugin and everything work's great
A pc with SainSmart photo
https://scontent-a-cdg.xx.fbcdn.net/hphotos-prn2/t31.0-8/1979906_10203379149664685_2038118978_o.jpg

PS:
1) i know my problem is the boot-loader because of a segmentation fault error from my Java Desktop Application  for  my controller
2)In this solution of Parallel Programmer you have to use an external power of your Arduino ( over the AC or over USB )

wittgenstein

I doubt this is much help, but:
My sketch was uploading just fine and then suddenly started timing out. I removed the 3.3v jumper lead to my accelerometer and it started working fine again. I have read that someone else solved the problem by removing the 5v jumper. I don't know what would cause that. I've examined my soldering for short circuits etc., but it all looks OK to me.

kishigo

Maybe this will help.
I was having this exact same problem of timing out.  It was consistent and interminable and irritating.
Here is what I did to fix it.
Change from using the USB to power the 2650 to a separate power supply.  I noticed in the documentation for the Arduino's there is a comment that if you use the USB +5V and the power is not clean or varies, the board will be unstable.  On a hunch, I went and dug out a 12V 3.3A separate power supply and connected it.  The timeout issue immediately disappeared.

kishigo

Well, maybe power supply won't help.  Now it's back to timeout.  Strange.

kishigo

#79
Apr 16, 2014, 11:06 pm Last Edit: Apr 18, 2014, 07:11 am by kishigo Reason: 1
Once again working reliably.  On my linux PC, it seems to matter that the USB is on USB bus 1.  I used the lsusb command to figure out which usb bus the cable was on.  I've seen weirdness with usb ports before.  The ones on the back seem to behave better.
A friend of mine who is a hw wizard explains that the usb ports on the back of the pc usually are more reliable because they are directly off the board while the ones in front require internal wiring to the motherboard.

gatoet601

hola soy de peru
tengo el problema de que cuando trato de cargar un programa desde la plataforma de programacion se demora en cargar y luego sale este mensaje:
Binary sketch size: 4560 bytes (of a 258048 byte maximum)
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout

bueno tengo windows 8 como sistema operativo sospecho que este bloqueo de alguna forma el arduino mega 2560 R3
┬┐como puedo solucionar este problema? help (agradesco des ya vuestra respuesta).

ioanbsu

Here is what happens to me.
I have several computers and I have timeout only on my mac book pro latest generation.
On my hp with win 8 seems the upload process goes correctly.

Any idea why it may not work on mac only and work on win 8?

p.s. I don't remember I installed any drivers on win8 at all, which kin-da weird to me.... i think I read somewhere drivers installation is required.

ioanbsu

Ok, solution that was posted here worked for me:
http://forum.arduino.cc/index.php?topic=198539.0

whitesmoker

Hello !

I solved a problem so.
1. It is necessary to press the RESET button on Arduino and to hold it.
2. To press -> in the program and after completion of compilation to release the button.
Loading happens without problems.

tonysnark

After reading this thread I found my own solution to this problem!

I was using a USB hub on my display to upload to my Arduino Mega. I tried to plug it directly into the front USB bus on my computer, and it worked!

no idea why...

anvoice

#85
Sep 21, 2014, 11:07 pm Last Edit: Sep 22, 2014, 10:03 am by anvoice Reason: 1
Hello,

I started having this issue too all of a sudden with my rather new atmega 2560: it worked flawlessly for about a month, then this.

Edit: I successfully flashed the bootloader. Visibly, a difference is that now the orange "L" LED blinks instead of staying lit. However, the timeout error still persists and I can't upload a single sketch... Any ideas? Ready to climb a wall here.

Maheshchiramure

I am using "Arduino Mega 2560" and am also facing the same problem. Post "#10" works for me "sometimes" but still isn't the "Proper" solution. Post "#11" is not working for me at all. Isn't there a scientific solution to deal with this problem ?

nickgammon

#87
Oct 28, 2014, 11:13 pm Last Edit: Oct 28, 2014, 11:14 pm by Nick Gammon
@Maheshchiramur: Please do not cross-post. This wastes time and resources as people attempt to answer your question on multiple threads.

Stick to : http://forum.arduino.cc/index.php?topic=275448.0

Don't just piggy-back your question onto the end of lots of other threads.

- Moderator
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics

schuimpge

Time-Out problem here also..

Name is Luc, first post here..

Noticed that once connected, my AtMege2560 has no problem with the first Sketch Upload.
But the second one starts  giving problems.

After trying a couple of times, I've found that  unplugging the USB-cable (power from iMac USB port) allows me to upload a sketch without any problem.
So for now, just unplug USB-cable before I upload....

Hope this benefits some more people.

Regards,
Luc

mrmaniacal

tonysnark's answer worked for me, looks like the USB hub wasn't providing clean enough power, plugging directly into the computer fixed the issue.

Go Up