Go Down

Topic: Associer .ino avec Arduino.exe 1.0 (Read 7496 times) previous topic - next topic

Voilelec

Dec 20, 2011, 05:56 pm Last Edit: Dec 20, 2011, 06:59 pm by Voilelec Reason: 1
Bonjour

Il semble qu'il existe un problème sous Seven 64 bits avec l'association de l'extension .ino lorsque la directorie Arduino est sur le disque D:

Il n'est pas possible de valider dans les préférences "Automatically associate .ino files with Arduino", cela se perd an sortant.
cet inconvénient n'existait pas les .pde en version 022.

Dans les propriétés des fichiers .ino, il n'est pas possible de choisir Arduino.exe.
En principe "filetypesman-x64" résout très bien ces incompatibilités, mais pas dans ce cas.

Avez-vous réglé cette difficulté ?

Merci et amitiés.

skywodd

Bonjour,

Pour associer les .ino avec arduino 1.0 :
click droit sur un .ino -> ouvrir avec ... -> cocher toujours ouvrir (...) -> parcourir -> choisir chemin jusqu'à arduino.exe -> ok -> sélectionner arduino.exe -> ok

A partir de là tout les .ino s'ouvriront avec arduino.exe
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

Voilelec

Merci

Mais comme je le signalais, cela ne fonctionne pas dans les conditions précisées, soit : Seven 64 bits et D:

...

skywodd

J'ai windows 7 64bits, arduino 1.0 sur mon disque D: et cela marche sans aucun probléme :smiley-eek: est ce que ton installation est correcte ?
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

unisev

J'ai exactement le même problème avec la version 1.0.1 sous Seven 64 bits.

On ne peut pas associer le PGM arduinio aux fichiers .ino et ce, même s'il est sur le C:, j'ai été administrateur Microsoft et c'est bien la première fois que je vois ça !

Sev
EN: Libraries are my Gurus, they make me believe anything they want !
FR: Les librairies sont mes gourous, elles me font croire ce qu'elles veulent !

OLIVIERC67


J'ai exactement le même problème avec la version 1.0.1 sous Seven 64 bits.

On ne peut pas associer le PGM arduinio aux fichiers .ino et ce, même s'il est sur le C:, j'ai été administrateur Microsoft et c'est bien la première fois que je vois ça !

Sev


Et dans la base de registre, est ce que l'association ".ino" est déjà occupé ?

Sous XP 32bits, c'est là (désolé, j'ai lâché ouinouin à partir de vista):
HKEY_CLASSES_ROOT\.ino

Si c'est le cas, peux tu me donner le programme associé.

J'ai déjà eu un problème similaire il y a quelques années sous XP avec un programme qui squattait une extension.





skywodd


J'ai exactement le même problème avec la version 1.0.1 sous Seven 64 bits.

De mémoire la technique pour modif une extension de manière forcé c'est :
logo windaube -> "programme par défaut" -> "associer un type de fichier à un programme" -> chercher ".ino" das la liste -> si la clef existe -> "changer le programme ..." -> sinon regedit.exe -> "HKEY_CURRENT_USER\SOFTWARE\Classes" -> ajouter une clef  -> .ino -> recharger la liste  "programme par defaut" -> changer le programme de .ino
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

barbudor

Win7 Home Premium 64 Bits avec mon Arduino dans D:\Projets\tools\Arduino
Aucun problème pour ouvrir les sketchescroquis ;)

unisev

#8
Jun 15, 2012, 10:52 am Last Edit: Jun 15, 2012, 10:55 am by unisev Reason: 1
Ce qui est drôle c'est que Windows ne considère même pas Arduino.exe (même s'il se trouve sur le disque C:) comme un programme puisqu'on peut asscoier les INO avec n'importe quel autre soft.

Voici le mouvement d'esquive de ouine-ouine en image :

ETAPE 1 - Je vais chercher le PGM à associer :



ETAPE 2 - Après avoir cliqué sur Ok à l'ETAPE 1, je devrai le retrouver dans la liste en présélectionné :



Mais que nenni !!

Pour la base de registre je vais approfondir, car l'emplacement que vous donnez ne contient pas les liens vers les programmes associés, mais il permet au moins de supprimer le type de fichier connu pour repartir du début.

Sev

HS : Barbudor, tu tombe bien, j'ai des question à propos de ton soft timer, je file dans ton sujet de ce pas !
EN: Libraries are my Gurus, they make me believe anything they want !
FR: Les librairies sont mes gourous, elles me font croire ce qu'elles veulent !

skizoh

Bonjour, je suis passez par la par hazar et je me demandais si ça pouvais t'aider:

assoc .ino=Arduino.Document
ftype Arduino.Document=C:\SPC\arduino-1.0-windows\arduino-1.0\arduino.exe %1

commande winows pour associé les .ino  une certain type, d'origine le logiciel configure lui même ino = Arduino.Document et après lié Arduino.Document à ton .exe , ces deux ligne à mettre dans un fichier .bat et pis voila ! :) Peut être que ça t'aidera sinon tampi. ^^"

Skizo !

unisev

Oui, ça fonctionne, mais il faut lancer le script "en tant que Administrateur", les privilèges administrateurs ne suffisent pas.

C'est en fait pour la même raison que l'option "Associer automatiquement les fichiers .ino avec Arduino" ne fonctionne pas dans l'appli Arduino, il faut la lancer en tant que Administrateur.

Merci pour votre aide à tous  :)

Sev
EN: Libraries are my Gurus, they make me believe anything they want !
FR: Les librairies sont mes gourous, elles me font croire ce qu'elles veulent !

skizoh

arf d'accord :s bon courage pour devenir administrateur alors ^^

unisev

Je me vois donc dans l'obligation d'éclaircir ce point...
Pour éxecuter en tant qu'adiministrateur, il faut faire un click-droit puis :



;)
EN: Libraries are my Gurus, they make me believe anything they want !
FR: Les librairies sont mes gourous, elles me font croire ce qu'elles veulent !

barbudor

Et pourquoi ne pas laisser Arduino.exe s'enregistrer tout seul ?

File -> Preference -> Automatically associate INO files with Arduino.exe

C'est comme cela que j'ai fait sur mon Win7 64bit

unisev

#14
Jun 15, 2012, 01:48 pm Last Edit: Jun 15, 2012, 01:52 pm by UniseV Reason: 1
Parce qu'il existe des gens pour qui ça ne marche pas, je vais essayer d'être clair :

Que se soit par le script (CMD) ou le soft (Arduino), pour que la mise en place de l'association fonctionne, il faut que le programme qui le fait quel qu'il soit, soit lancé par l'Administrateur Windows.

Un utilisateur qui à les privilèges administrateur ne suffit pas, ceux qui ont ce problème ne sont surement pas loggé sur Windows en tant qu'Administrateur.

La solution est donc de faire un clic-droit, "exécuter en tant qu'Administrateur" sur le soft Arduino, ainsi l'option dont tu parles fonctionnera.

Sev

Barbudor EDIT:Tu dois être loggé en tant qu'Admin sur ton W7

Barbudor HS : J'ai posté dans le sujet sur ton SoftTimer
EN: Libraries are my Gurus, they make me believe anything they want !
FR: Les librairies sont mes gourous, elles me font croire ce qu'elles veulent !

Go Up