Go Down

Topic: Problem with Arduino Ethernet (Read 1 time) previous topic - next topic

guest1102

Hy everybody,

I've just bought the Arduino Ethernet. I uploaded the Ethernet WebServer sketch and plugged it into my network.
Both leds under the ethernet jack (green and orange) light up. The LED L9 behaves strange and flickers if I touch grounded parts such as the groundshield of the jack. Sometimes the RX Led goes on and the orange Led goes off simultaneosly. Also the Wiznet IC gets "hot", about 50°C. Is that normal?
However, I tried to enter the IP in my browser, but the browser was not able to connect to it.

I would be happy if somebody knows the solution, I really don't know what could be wrong, maybe a bad board?

Andy

pe1br

Is this ip number in your own network range ?
otherwise you have to change the ip in the sketch or change the adres of your pc.

zoomkat

Wiznet chips run on the hot side.
Google forum search: Use Google Search box in upper right side of this page.
Why I like my 2005 Rio Yellow Honda S2000  https://www.youtube.com/watch?v=pWjMvrkUqX0

guest1102

Thank you for your quick reply.

The IP should be in my range. I have a Netgear router, my PC and TV have IPs like 192.168.0.3, so I gave my EthernetBoard 192.168.0.15. I also took the recommended MAC (written at the bottom of the board).
The MAC and IP didn't even show of on the "attached devices" site of my router.
I also tried to use the new DHCP function in Arduino version 1.0, but the same problem as before.

The board seems not to respond the routers data (RX LED blinks, but no reaction on the TX LED).

In my previous post I mentioned the strange flicker on LED 9. is that normal, could it have to do with the problem?

zoomkat

Some client test code you can tweek for your setup and try.

Code: [Select]

//zoomkat 12-08-11
//simple client test
//for use with IDE 1.0
//open serial monitor and send an e to test
//for use with W5100 based ethernet shields

#include <SPI.h>
#include <Ethernet.h>

byte mac[] = { 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED }; //physical mac address
byte ip[] = { 192, 168, 1, 102 }; // ip in lan assigned to arduino
//byte gateway[] = { 192, 168, 1, 1 }; // internet access via router
//byte subnet[] = { 255, 255, 255, 0 }; //subnet mask
byte myserver[] = { 208, 104, 2, 86 }; // zoomkat web page server IP address
EthernetClient client;
//////////////////////

void setup(){

  Ethernet.begin(mac, ip);
  //Ethernet.begin(mac, ip, subnet, gateway);
  Serial.begin(9600);
  Serial.println("Better client test 12/01/11"); // so I can keep track of what is loaded
  Serial.println("Send an e in serial monitor to test"); // what to do to test
}

void loop(){
  // check for serial input
  if (Serial.available() > 0) //if something in serial buffer
  {
    byte inChar; // sets inChar as a byte
    inChar = Serial.read(); //gets byte from buffer
    if(inChar == 'e') // checks to see byte is an e
    {
      sendGET(); // call sendGET function below when byte is an e
    }
  } 
}

//////////////////////////

void sendGET() //client function to send/receive GET request data.
{
  if (client.connect(myserver, 80)) {  //starts client connection, checks for connection
    Serial.println("connected");
    client.println("GET /~shb/arduino.txt HTTP/1.0"); //download text
    client.println(); //end of get request
  }
  else {
    Serial.println("connection failed"); //error message if no client connect
    Serial.println();
  }

  while(client.connected() && !client.available()) delay(1); //waits for data
  while (client.connected() || client.available()) { //connected or data available
    char c = client.read(); //gets byte from ethernet buffer
    Serial.print(c); //prints byte to serial monitor
  }

  Serial.println();
  Serial.println("disconnecting.");
  Serial.println("==================");
  Serial.println();
  client.stop(); //stop client

}

Google forum search: Use Google Search box in upper right side of this page.
Why I like my 2005 Rio Yellow Honda S2000  https://www.youtube.com/watch?v=pWjMvrkUqX0

guest1102

Sorry, but I can't use the arduino 1.0 ide with my ethernetboard (Thats an other problem I have, but the older version works fine for me now, so I will search the problem later)
Unless I'm mistaken, your sketch needs an internet connection to connect to your server. Sorry but I'm not ready yet to give the microcontroller access to the web. I would be glad if I get it running in my own network  :smiley-red:.

guest1102

Problem solved
I don't know exactely why, but after trying it again the next day it worked.
I think the problem was the IDE. It showed "done uploading", but it wasn't uploaded. Then after reinstalling the IDE it has worked.

Go Up