Go Down

Topic: Driver Issues (Read 1 time) previous topic - next topic

NoroNoroBeam

Hello,

I have been trying to install my Arduino Uno (ATMega328P) on a school computer.

I was able to download the IDE (the one without administrative privileges). After downloading, I extracted all files to the desktop and ran the IDE with the "Blink" program example. It worked once no problem, then after that (and every time after that I have tried), it has come up with the following error: avrdude: stk500_getsync(): not in sync: resp=0x00

I checked my device manager and noticed that the Arduino comes up as an unidentified device (see picture). I researched the solution to this problem on this forum and it said to install the drivers. So I did that (see picture). However, after attempting to install the drivers I get an error that says "access denied" (see picture). I researched the solution to that problem... a few of them actually, involving turning off hidden/read only and some other tricks... no matter what I seem to do, I keep ending up with a Driver that won't install and an Access denied.

Is there anyway to get a driver on a machine without administrative capabilities? Any tricks or tools will be helpful.

I already asked the IT professional at my school and he told me that we are not allowed to log in administratively to add these programs due to protocol... so whatever I have to do needs to be a local/virtual fix with out administrative approval.

Thanks for your help in advance

Cheers

AJITnayak

Which version of arduino ide UR using. ??

IS it your first time do programming on arduino. If yes check whether blink program already uploaded being working or not??
AMPS

NoroNoroBeam

It is the IDE 1.0.5 found (http://arduino.cc/en/Main/Software#toc1)

Specifically, I downloaded the

"Windows ZIP file (for non-administrator install)
NOTICE: Arduino Drivers have been updated to add support for Windows 8.1, you can download the updated IDE (version 1.0.5-r2 for Windows) from the download links below."

I've tried every article in this forum I could find on the topic
I've tried change the "read only" privileges of the folder and all sub folders
I've tried going into the device manager and installing the port drivers by hand
I've tried going into the device manager and installing the drivers by folder (as opposed to the port technique)

The software runs fine on my computer at home (where I have administrative privileges), but here at my school, I cant get the computer to recognize the board itself on the com port (because it won't install the drivers and I can't get it to do so due to the "access denied" wall I keep hitting)


AJITnayak

From the image it can clearly say that u have not chosen correct path,

D:\arduino-1.0.5-r2\drivers
Inthis you need to select the driver path. Even i am using arduino 1.0.5 windows 7 . I am not facing any problem.
AMPS

NoroNoroBeam

When you install drivers and select a folder, it includes all subsets.

In fact, if you read the error message it says "Drivers found". The problem isn't locating the drivers (I can even click them manually to install them), the problem is that when I go to install, there is an "Access Denied" and that is what I need to get around...

Apparently, there should be a way to install these drivers without administrative privileges (since other people have posted that they have been able to do so... just none of their methods work on my school machine).

Again on my home computer, I have ZERO problems with the board. I downloaded the IDE and it installed drivers and everything... works great. On two of my computers! My problem is that I want to work on it at school and I am unable to get it properly working on school computers.

Thanks though. Any other ideas?

AJITnayak

Its because you havent located the Driver folder properly. Just zip driver folder paste it in your Arduino IDe folder. Then go manually Driver selection path
AMPS

NoroNoroBeam

I'll try that again tomorrow when I get to school and let you know how it works :)

For now, thanks :)

Go Up