Go Down

Topic: In what IDE do you write libraries for Arduino? (Read 8272 times) previous topic - next topic

avenue33

I use Xcode to write libraries.

I need code-sense and some extra features the Arduino IDE doesn't provide.

I've developed a template for Xcode, embedXcode. Code is here and documentation there.



Contrary to Eclipse, NetBeans and Visual Studio, Xcode is rather secretive about its inner structure, so developing the template isn't that easy.

embedXcode works fine. :)

gerg

I was literally just getting ready to post a link to this.

For most users who want a real IDE, something like codeblocks should be a massive step up from the Arduino IDE.
http://maniacalbits.blogspot.com

Jantje

Avenue33

Contrary to Eclipse, NetBeans and Visual Studio, Xcode is rather secretive about its inner structure, so developing the template isn't that easy.

Maybe eclipse is more open but to call eclipse plugin development easy is a bridge to far 8)
Best regards
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

jimford

Is anyone using the arduino-mode for Emacs?

I installed it in emacs 23 (and also a 24 snapshot), and initially it worked fine. I got highlighting of the code and best of all was able to compile and upload it to the arduino using EDE. I also got a serial window. It seems to be broken now, and all I get is the highlighting, but not the compile/upload/serial window functions.

I've tried uninstalling and reinstalling emacs, but it makes no difference.

Does anyone know what the problem might be, please?

Jim

westfw

Quote
emacs

I didn't know that anyone had gone and done an arduino-mode !

It looks like there is an "arduino-mode.el" that does basic C-style stuff, but compilation/upload is part of CEDET instead?
http://www.emacswiki.org/emacs/CollectionOfEmacsDevelopmentEnvironmentTools


stanleyhuang

My Arduino blog: http://arduinodev.com/blog

jimford


Quote
emacs

I didn't know that anyone had gone and done an arduino-mode !

It looks like there is an "arduino-mode.el" that does basic C-style stuff, but compilation/upload is part of CEDET instead?
http://www.emacswiki.org/emacs/CollectionOfEmacsDevelopmentEnvironmentTools


I had CEDET installed and Semaintic and EDE enabled. The frustrating thing is that initially the compilation and upload to an arduino worked so well!

Jim

gerg

Did you try cleaning up your .emacs stuff and/or find any local project files created by EDE and/or CEDET?
http://maniacalbits.blogspot.com

Go Up