Go Down

Topic: 7805 Saca demasiado voltaje + duda circuito (Read 11782 times) previous topic - next topic

Sergegsx

Feb 27, 2012, 08:24 pm Last Edit: Feb 27, 2012, 08:28 pm by Sergegsx Reason: 1
Hola, a ver si podeis iluminarme porque estoy perdido. dos cuestiones...

1) tengo un circuito que usa un 7805 para regular tensión de 9V a 5V. El primer problema que veo es que si mido con un tester estoy leyendo mas de 6 voltios de salida, he probado varios reguladores y con todos me pasa igual.
(necesito 5V bastante exactos porque lo que luego hago es un divisor de tensión para pasar a 2,5V que es la mitad de lo maximo aceptable por un pin analogico. actualmente me salen casi 4V despues del divisor de tensión y esto es un problema.


A pesar de lo anterior todo funcionaba bien y decidi añadir la segunda parte al circuito...
2) el segundo problema es que añadi un circuito para poder medir con el arduino la tensión de 9Vac (si AC) que saca mi trafo. Pero parece ser que lo he quemado. El circuito en que me baso es este


y mi circuito diseñado es este.





Uploaded with ImageShack.us
(de la foto de arriba, la pcb tiene 4 secciones empeznado por abajo:
la primera rectificar a DC,
la segunda regular a 5V,
la tercera divisor de tensión a 2,5V para crear un offset y poder medir con sensores de corriente
y la cuarta el circuito necesario para medir 9Vac.


Con el consigo hacer 2 cosas
1) rectificar y regular a 9Vdc para alimentar el arduino
2) ajustar los 9Vac para poder leerlos con un analog input del arduino.

no pretendo que analices mi circuito, pero vamos si tenéis alguna idea de que puede estar pasando o que puedo probar antes de quemar otro trafo que acabo de comprar os lo agradeceria.

riscking

#1
Feb 27, 2012, 09:05 pm Last Edit: Feb 27, 2012, 09:11 pm by riscking Reason: 1
La parte del esquema que sale de los 9vac y va la primera borna de arriba no la acabo de entender el porque esta ahi, no esque sea un hacha con la electronica pero la veo sobrante con los diodos rectificas con los condensadotes la filtras y tendrias algo mas de 9vdc estos los regulas y haces el divisor a 2,5, el resto no se, igual esta bien no se de ser asi estaria bien explicarlo.

Lisergio

podrías poner el esquema eléctrico del montaje... siguiendo las pistas uno se lía....

un saludo

Sergegsx


La parte del esquema que sale de los 9vac y va la primera borna de arriba no la acabo de entender el porque esta ahi, no esque sea un hacha con la electronica pero la veo sobrante con los diodos rectificas con los condensadotes la filtras y tendrias algo mas de 9vdc estos los regulas y haces el divisor a 2,5, el resto no se, igual esta bien no se de ser asi estaria bien explicarlo.


hola riscking, esa parte es la que adapta la señal de 9Vac para leerla con un pin analógico. Es la correspondiente a la del esquema que he puesto un poco mas arriba a color que pone "power adapter". Si entiendo bien lo que hace son dos cosas:
1) por un lado coge 5V y mediante un divisor de tensión lo pasa a 2,5V. (esto se usa porque vamos a leer ALTERNA y si centramos la lectura en cero cuando oscile hacia abajo podría dañar el arduino, por lo tanto subimos el "cero" a 2,5V y que oscile en ese punto
2) coge los 2,5V y le añade mediante lo que yo creo que es otro "divisor de tensión" la parte de los 9Vac. el resultado de estos dos lo envía al pin analógico.
aclara esto el esquema? vamos yo creo que funciona así.

todo esto es porque quiero leer los 240Vac de la casa y por tanto lo paso a 9Vac y luego leo con el arduino con esa parte del circuito.

Sergegsx


podrías poner el esquema eléctrico del montaje... siguiendo las pistas uno se lía....

un saludo


hola lisergio!
pues voy a intentar hacer un poco fotomontaje sobreponiendo una imagen con la otra. ya he puesto el esquema electrico sacado de fritzing pero lo cierto es que no es una replica exacta de mi circuito aunqeu si muy cercana.

se que es complicado ayudarme, pero no perdia nada por preguntar.

lo que si que creo que es mas facil de contestar es porque el regulador me saca 6 voltios y pico? alguien lo sabe?

Sergegsx


lo que si que creo que es mas facil de contestar es porque el regulador me saca 6 voltios y pico? alguien lo sabe?

tiozes

La verdad no se decirte porque el regulador te da mas tensión, pero el consejo que te doy es usar reguladores variables, le metes un potenciometro y regulas a tu gusto, asi te dejas de problemas de tener V de mas.


Saludos

Sergegsx


La verdad no se decirte porque el regulador te da mas tensión, pero el consejo que te doy es usar reguladores variables, le metes un potenciometro y regulas a tu gusto, asi te dejas de problemas de tener V de mas.


Saludos


Gracias x la sugerencia! Creo q es buena idea, pero yo pensaba q el regulador forzaba 5V.
Donde deberia de poner la resistencia o el potenciometro?

IbnuAlHaizam

Igual estás usando un 7806  :P. Si pusieras el esquema eléctrico estaría más claro.

ToloBCN

¿Has probado con otro tester? muchas veces he medido la salida de un 7805 y siempre 4.98-4.99

SrDonGato

#10
Mar 01, 2012, 05:00 pm Last Edit: Mar 01, 2012, 05:25 pm by SrDonGato Reason: 1
el problema lo tienes en el diodo que tienes en serie con el GND del 7805, la patilla central tienes que llevarla directamente a GND

un regulador de la serie 78xx y 79xx se pueden hacer regulables poniendo un potenciómetro entre la patilla GND y GND.

lo que mides a la salida del 7805 es la tensión regulada a 5 voltios mas la caída de tensión que tienes entre la patilla central del 7805 y GND


ni caso, he mirado mal el esquema

Sergegsx

jeje gracias de todas formas señor don gato,

he probado con una fuente de alimentación a 12Vdc y metiendoselo directo al 7805 y la lectura es mucho mas cercana a 5V. en cambio si uso la fuente de AC-AC a 9Vac y lo paso por el puente de diodos y los condensadores entonces me da por encima de 6V.
se supone que la fuente es de 9Vac pero tras rectificarlo me marca por encimade 13Vdc el tester por lo que igual algo tiene que ver. o incluso como apuntais el tester no esta midiendo bien.

alguna idea de porque con la fuente de DC va bien y con la de AC se pasa de voltage?

he decidido rehacer el circuito para evitar quemar otro trafo por lo que este finde lo hare a ver que pasa. ya os contare como va la segunda cuestion del post.

gracias chicos

riscking

Cuando rectificas ac siempre sale algo mas en este caso de 9 a 13 podria estar bien, no me acuerdo la razon exactamente pero era asi, por otro lado la señal de la primera borna q la quieres para medir el paso por 0 o algo asi?

Cheyenne

9 V en alterna es la tensión eficaz de la senoide. Al rectificarla y poner el condensador, éste se carga a la tensión máxima, la de pico, que en una senoide es el valor eficaz por raiz de 2. 9 por raiz de 2 da 12,7 V.
http://cuadricopterodiyarduino.blogspot.com/

Sergegsx

muchas gracias a los dos por la explicación del sobrevoltaje que estaba viendo.

riscking evectivamente de la primera borna me lo llevo al otro lado de la placa para medir el voltaje y el paso por cero. y he comprobado que todo el circuito funciona bien si quito esta parte. no me he atrevido a conectar el trafo con esta seccion del circuito conectada xq creo que es ahí donde radica el problema. este fin de semana veré si encuentro el fallo aunq incluso puede ser que todo funcione bien pero no me atrevo a conectarlo.

si consigo que no se me queme el trafo otra vez y dejo todo funcionando ya explicare aqui mejor para que va a servir este modulo en mi proyecto.

gracias !!!

Go Up