Go Down

Topic: Missing digital signature for driver on Windows 8 (Read 232385 times) previous topic - next topic


Made the upgrade to Window 8 Pro this weekend.  All things considered I have noticed a good speed increase over Windows 7.  No major issues except when I plugged my quad into the USB port Mission Planner couldn't find it. So....
After a bit of digging I found this post: http://arduino.cc/forum/index.php/topic,94651.msg716650.html
in which I found a solution that I thought would be helpful to post here for others.
I'm running Mission Planner 1.2.14
Download the 3 files below
Double-click on the .cert file
Click "Install Certificate"
Select "Local Machine"
Select "Place all certificates in the following store" radio button
Click "Browse"
Select "Trusted Root Certificate Authorities"
Click OK
Finish etc...
Repeat  the process, starting at step 2, replace step 8 with "Trusted Publishers"
Once you've added the .cert to both folders, right click on the arduino.inf file and choose "Install"
Open Mission Planner
This worked for me first try.  Thanks to Louis @ Arduino for the great instructions, just thought I could save some folks a bit of time by relaying my direct experience with Mission Planner.





Thanks a lot. It really helped...
Now my arduino is up and running together with this (*!~~&$!) Windows8.


Thanks! I thought I would have to uninstall window 8


Thanks! I thought I would have to uninstall window 8

In itself not a bad idea <grin>
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics


if my arduino disconnects i have to do the whole reinstall off the drivers using the erw package and it takes a few tries to get it to work using windows 8. If i need to unplug it, it can take up to 30 minuets to fix. There a fix for this?


hi guys!
I see its been sometime since the last post I hope anyway sb help
I tried downloading the drivers of arduino in my windows 8 computer but I was not able to open the arduino.inf so I suppose sth is wrong does anybody have aby idea?Furthermore I had the following message "avrdude: stk500_getsync(): not in sync: resp=0x00" and I am wondering if that has to do with that I could not intsall the arduino.inf
thanx indeed


This procedure did appear to work on my new ASUS  X202E laptop. Shutdown.exe /r /o /f /t 00  must be entered EXACTLY with spaces.  I was able to bypass (disable) the file signature issue.  I now have the MEGA 2560 R3 driver installed. However, simple sketches like "blink" will still not compile.  Anyone else have this problem?


Found the alleged "correct" driver for the Mega 2560 R3 with the security sig. Installed it and still didn't work with windows 8 and my ASUS X202E laptop with touchscreen.  HOWEVER, I went into compatibility check and set compatibility to Windows 7 and all is well (this same MEGA and cable HAS always worked with windows 7 and my HP desktop machine, so I knew the board and cable were ok).



Here is a step by step guide that workscperfectly, you just have to disable the digital signature enforcment.


These are for windows 8.1

for separate x86 and x64 driver you can use 
you need to install them manually from device manger. first for the FTsomething unknown device and then for the Virtual com port both drivers are in the same folder.
I used this method  and it worked for me.

Another method is to get the setup to do this for you.
for a driver setup use


I've read and tried the various solutions offered, but with 64 bit it doesn't seem to work.
You aren't allowed some of the options needed.
Anyone got a solution that works on the 64 bit, Windows 8.1 system?


if using win8 64 bit, you download the software Driver Pack at the link http://adf.ly/u3y7S . For the other win, you look at the software Easy Driver Pack blog: http://storesofts.wordpress.com/ultility/


I have a custom pc running windows 8.1 pro 64 bit -- how do I do this on windows 8? I get "the device cannot start (code 10)" and "There is no device at the specified location.". Help!

Go Up