Go Down

Topic: Arduino Does Not Show Up Under Ports (Read 52023 times) previous topic - next topic


I have Arduino Uno. I'm running Windows XP. I installed it with the Found New Hardware Wizard. I may've installed the wrong drivers, though - the fdti(or whatever sounds similar to that)and Arduino does not show up under ports.  Any suggestions?

Louis Davis

The UNO does not use the FTDI drivers.

Follow these installation tips:

Let us know if you have any more problems.


Thanks. I saw that link yesterday but I would need to *actually* be able to see arduino under ports to be able to participate in that link and the problem is I DON'T SEE ARDUINO UNDER PORTS. Plus if I put the wrong drivers in - I need to know how to remove them and put the right drivers in.

Louis Davis

Do you see an Unknown Device in Device Manager when you plug in the Arduino?
If so, follow the steps to install the driver on the Unknown Device.

If you don't see anything show up when you plug in the Arduino, then you should try a different USB cable and make sure you are not plugged into a USB hub.


There are no unknown devices. I don't have a USB hub. The current USB cable must be doing something because the arduino lights up when it is plugged into the computer.


Does the Device Manager refresh if you connect the Arduino board when it's open?  If so, you should get some sort of device for it (that you could update the drivers for).  If not, you might try a different USB cable; it's possible that it's providing power but the connection isn't reliable enough for data communication.


The Device Manager does refresh if I connect the Arduino Board  - I just tried it. But there is no obvious Arduino device under ports or anywhere else. And no generic device listed in the Device Manager. You have any suggestions as to what I would be looking for and where?


In Device Manager do you happen to have a new COM port showing up under Ports (COM & LPT)? Open up this tree before plugging in the card.


I just did what you said - I opened up the tree before putting in the card and all I got was: Com1 and Lpt1. I use to get Com3 but I probably screwed it up by putting an arduino uno driver in it - how can I remove that? Any other ideas in terms of having Arduino show up in the device manager?

Louis Davis

Download the following utility that will help with troubleshooting your USB problems:

Execute the following command before connecting the Arduino to the system:
USBDeview.exe /stext before.txt

Then connect the Arduino to the system and execute this command:
USBDeview.exe /stext after.txt

Send both text files created to this thread. (before.txt and after.txt)

This will give a snapshot of all the USB devices on your system and their states. Hopefully this will point to the problem.

If you run the tool without any command line arguments, it will give you a GUI interface that will allow you to do all kind if things with USB devices. I find it a very useful tool for USB troubleshooting and development.


Did you solve this problem. I have the same problem.

I have an Arduino Uno.

Arduino is not showing up in device manager (not in ports or as an unknown device).

The light is coming on and it looks like it came loaded with the blink program because it is blinking.

I tried changing the USB cable. Nothing.

I tried changing the PC 3 times. First with the IDE installed on my windows 10 computer.
Second time on my windows 7 computer without IDE installed.
3rd time on a MacBook.

Everytime it was the same. Lights come on, on the board but nothing is registered on the computer.

Any ideas?


@ Jtrusbak

This thread is very old and very unlikely to be the same situation as yours.

I would suggest you start your own thread after you have read the post about HOW TO USE THE FORUM !

There is specific information that is often required and you made a decent start Lets just get you on the right track.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google (who would have thunk it ! ) or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.


I am on a Mac and solved this problem by updating my apple software. It completely solved the problem. Try seeing if you have any software that needs to be updated on your computer before proceeding with anything else.



They are talking "windows" not apple.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google (who would have thunk it ! ) or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up