0021 ubuntu 10.10 64bit

I already have 18 installed from the package but want to upgrade to 0021. The IDE opens and serial monitor works but everytime I try to download code to the board I get the following error:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

It downloads fine on my 0018 IDE packaged with ubuntu. How do I fix this.

Thanks in advance.

I looked at it a little more. It looks like for what ever reason it does not upload correctly using the avrdude included with 0021 is there a way I can make it use the avrdude ubuntu packaged

What board and cable are you using?

You should be able to replace the avrdude and avrdude.conf files in the Arduino distribution with symlinks to the distribution's versions.

I have the same problem. I'm using Arduino Diecimila on Ubuntu 10.04 32 bit. It works fine with Arduino 0018 Ide packed for Ubuntu, but i tried with the versions 0021, 0019 and 0018 (!), the generic one, not packed for ubuntu, and i have the same output than Sleepercivic:

avrdude: stk500_recv(): programmer is not responding

With the 0021 version, I tried mellis workaround, going in arduino-0021/hardware/tools directory and replacing the files with symbolic links to ubuntu versions, in this way:

ln -s ln -s /usr/bin/avrdude avrdude
ln -s /etc/avrdude.conf avrdude.conf

But it didn't work.

I have the same problem on Ubuntu 10.04 32bit, works fine with 018 from PPA but not with any other version downloaded from arduino.cc. I also tried to symlink avrdude and .conf.
(Arduino Duemilanove (atmega328))

I'm running Ubuntu 10.10 64bit, have installed Arduino0018 (the standard version in the software center), but want to install at least version 20, since I have an Uno board, and older versions don't seem to support it (correct?).

When I try to upload a sketch to the Uno with version 18, I receive the error message:
avrdude: stk500_recv(): programmer is not responding

I downloaded version 21 32bit from the arduino site, but once I have uncompressed the tgz file, I am unsure of how to install it so I can run it.
Apologies if this is the wrong thread for such a question, but any help with installation would be much appreciated.

I'm using Ubuntu 10.10 and I can get 0018 sortof working but no serial ports. 0021 doesn't start at all. Also I'm using a UNO .. well actually I haven't been able to do a thing because of this.

I’m trying to use a new Arduino Uno in Slackware 13.1 64 bit with Arduino IDE 0021 and it don’t uploads to the device and it gives me this

java.io.IOException: Cannot run program “/opt/arduino/hardware/tools/avrdude”: java.io.IOException: error=2, No such file or directory
at java.lang.ProcessBuilder.start(Unknown Source)
at java.lang.Runtime.exec(Unknown Source)
at java.lang.Runtime.exec(Unknown Source)
at processing.app.debug.Uploader.executeUploadCommand(Unknown Source)
at processing.app.debug.AvrdudeUploader.avrdude(Unknown Source)
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(Unknown Source)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(Unknown Source)
at processing.app.Sketch.upload(Unknown Source)
at processing.app.Sketch.exportApplet(Unknown Source)
at processing.app.Sketch.exportApplet(Unknown Source)
at processing.app.Editor$DefaultExportHandler.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: java.io.IOException: error=2, No such file or directory
at java.lang.UNIXProcess.(Unknown Source)
at java.lang.ProcessImpl.start(Unknown Source)
… 12 more

Maybe not the same thing because this package of slackware have some bugs. But in Slackware 13.1 32 bits the same package works “almost” fine.

But I have a machine with ubuntu 10.10 64 bit and I did successfully upload to Arduino Uno. But sometimes it says that /dev/ttyACM0 is not found or it is busy. It is strange…

I am also running Ubuntu 10.10 64bit. I installed both Arduino IDE version 018 and 021.
I had the same error "programmer is not responding" with my new Arduino Uno but it is solved for me now.

This is what I did:

Installed 018 from Ubuntu universe repositories via the software center under applications. Just search for Arduino and it will pop up in the list and click install.

I downloaded the 021 version from the Arduino website. (the tgz file for linux/ubuntu). I unpacked this to my home dir in /home/ruud/Coding/Arduino/arduino-0021/ and added a custom launcher to the panel with these properties:

Type: application
Name: Arduino IDE 021
Command: /home/ruud/Coding/Arduino/arduino-0021/arduino

018 does not seem to work. What I did was follow the instructions here:


to uninstall brltty

Next I started the Arduino IDE 021. I selected the UNO in the Tools > Board list and I changed the serial port to /dev/ttyACM0.

Next I could happily upload my sketches again to Uno and they run properly now. I am not sure which step in this did the actual work but by following my journey, you should get the same result I hope.

Good luck!

Had same problem as Kerml,

Clean install of 10.10,
downloaded latest Arduino 21, installed ok
So, carefully looked at what I had and what was missing.

I found I needed the 32 bit libraries

sudo apt-get install ia32-libs

Also check your version of librxtx-java.

More ideas from here Google Code Archive - Long-term storage for Google Code Project Hosting.

Works like a charm now.

Right, so now to do some new exciting stuff, maybe Eclipse :wink:

rockwallaby is happy now :smiley:

You might try modifying boards.txt to use the "arduino" upload type instead of "stk500".

I started by replacing the included avrdude binary with my system binary.

Unfortunately the included avrdude.conf doesn't have a definition for arduino, which you could add:

id = "arduino";
desc = "Arduino";
type = arduino;

After that you could modify the boards.txt file accordingly to be of type arduino for your board.

I'm using the git, version, but ended up modifying the programmer definition in the avrdude.conf because it was easy and quick(one edit as opposed to two).

id = "stk500v1";
desc = "Atmel STK500 Version 1.x firmware";
type = arduino;

Making things work in 64bit land has been a bit of an exercise in frustration, but I've learned quite a bit about how the IDE interacts with avrdude.

After re-reading the thread, combining 2 of the suggestions should work.

  1. Replace the avrdude.conf that is included with the one in /etc/avrdude.conf. Copy or symlink would be fine.
  2. Modify boards.txt to be arduino for your board.

Guys, I'm stuck with the today bought Arduino Uno. I've been able to upload and use it without any problems under Windows.. but now I'm trying to use it on my Archlinux 64bit system.

I followed what blacktip suggested on his last post and I've been able to upload a sketch.. but now the TX led stays on all the time even if I reset the board and I can't upload anything to the board.

Any suggestion?