017 visual elements duplicated(tabs,menus,status)

I see multiple copies of the toolbar and tab lines at the top of the ide window and the status line at the bottom.

I'm running IDE version 017 on vista with java 1.6.0_15.

Do other people still have this issue?

I have...

Vista Business service pack 1
Java 1.6.0_15-b03
Arduino 0015

No problems here.

only happens at IDE 017. I just can't believe it's been outstanding for months.

This is caused by a bug in the Java version that comes with Arduino 0017, and only happens on certain computers. You should be able to fix it by downloading the latest version of Java, and replacing the one in the Arduino application directory.

thank you very much.

Only took me an hour to figure out where java lives and how to replace it. Java version management is pants.

There seem to be several copies of java on each windows machine in my house.

and now the darned thing won't start - just a glimpse of the splash screen. grrrr.

restoring the java directory gets it running again (with the duplicated visuals). Enough diddling java, I just wanna code. Maybe release 18...

got a new java release today, once again I copied the jre directory into the arduino/java library and once again it's working - for now...

I live in hope.

I have this problem with:

Windows Home Premium 32-bit
Java 6 update 11
Arduino 0017

I have installed Runtime 6 update 17, and rebooted, but it did not fix the issue.

You mentioned replacing files in the Arduino installation directory-- what files do I replace, and where do I get them?



Okay, I figured it out and it's working, here are step-by-step instructions for others with the same problem:

Download and install Java Runtime 6 update 17 (JRE)
it's about halfway down the page.

Go to
.../Program Files/Java/jre6/
and copy all the files within that directory

Go to
and delete all the files within, then paste the files you just copied.

Fixed it for me...

good explanation - thanks.

Did you try just deleting the java directory to see if it would use the newly installed version? There must be some way to do that.

If you have Sun's JRE installed, you can just delete the "java" folder in the Arduino software (and get 80MB of space back). Arduino is able to find the installed JRE. I can verify that it works on my system (Vista Ultimate x64, JRE 6u15).

Thanks this worked for me with RC Windows 7 Ultimate. I also tried to delete the java directory in the arduino-0017 and this caused the software to not run at all. copied it back and it works like a charm.