1.6.11 is released - Let's talk about it here

As all of us probably know, IDE version 1.6.10 and boards version 1.6.12 was a catastrophe.

1.6.11 is now out and with it boards 1.6.13 - I thought it would be wise to start a thread dedicated to it, and try to get people to post information about any new 1.6.11 bugs and upgrade issues here, and discuss what is and isn't fixed here. I'll keep the top post updated as information is posted elsewhere.

I figured I'd post this before we had multiple threads on 1.6.11 new issues.


Did 1.6.10 do that?

I would try uninstalling, blowing away C:/users/(your username)/AppData (hidden folder)/Local/Arduino15 and reinstalling - in the hopes that it was something in there that confused it. It looks like it's choking while loading a package.


Looks like it was the seeed studio boards pack

Confirmed. It was caused by a missing tools field in their package_seeeduino_index.json file. Apparently that field is now required even if empty. A while back there were some issues caused by files with a missing tools field and the Arduino developer changed the code to allow it. Apparently there has been a regression in that behavior, caused by an overhaul of Boards Manager to fix some issues exposed by Arduino AVR Boards 1.6.12.

I have submitted a fix to the Seeeduino-Boards repository: https://github.com/Seeed-Studio/Seeeduino-Boards/pull/1

I looked through the Unofficial list of 3rd party boards support urls and found 3 more files with GitHub repositories that had a missing tools field: Balanduino, Goldilocks, and Sanguino. I have submitted pull requests to add the field:

Hi there

This seems to have been happening for a few releases, but I found 1.6.11 this morning and hoped that might fix it. Still the same issue.

The IDE times out waiting for the Genuino 101 to respond:
Arduino: 1.6.11 (Windows 7), Board: "Arduino/Genuino 101"

Sketch uses 16,784 bytes (10%) of program storage space. Maximum is 155,648 bytes.
Forcing reset using 1200bps open/close on port COM6
C:\Users\Dave\AppData\Local\Arduino15\packages\Intel\tools\arduino101load\1.6.9+1.24/arduino101load/arduino101load C:\Users\Dave\AppData\Local\Arduino15\packages\Intel\tools\arduino101load\1.6.9+1.24/x86/bin C:\Users\Dave\AppData\Local\Temp\build7ca66eee67b89f7ae3af88bb23ebe8e9.tmp/sketch_aug18a.ino.bin COM6 verbose
Starting download script...
Args to shell: [C:\Users\Dave\AppData\Local\Arduino15\packages\Intel\tools\arduino101load\1.6.9+1.24/x86/bin C:\Users\Dave\AppData\Local\Temp\build7ca66eee67b89f7ae3af88bb23ebe8e9.tmp/sketch_aug18a.ino.bin COM6 verbose]
Serial Port: COM6
BIN FILE C:\Users\Dave\AppData\Local\Temp\build7ca66eee67b89f7ae3af88bb23ebe8e9.tmp/sketch_aug18a.ino.bin
Waiting for device...
Waiting for device...
Waiting for device...
Waiting for device...
Waiting for device...
Flashing is taking longer than expected
Try pressing MASTER_RESET button
Waiting for device...
Waiting for device...
Waiting for device...
Waiting for device...
Waiting for device...
ERROR: Device is not responding.
ERROR: Device is not responding.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I've tried pressing the RESET and MASTER RESET buttons but it makes no difference.
I've attached screen grabs of the device manager during the upload process. AfterReset and BeforeUpLoad look to be the same. After Reset occurs about the 2nd line of Waiting For Device... in the second group. eg

Waiting for device...
Flashing is taking longer than expected
Try pressing MASTER_RESET button
Waiting for device...
Waiting for device... <---- Back from reset here

I tried dfu-util but it doesn't display anything in the list no matter when I run it.

I've even tried running the installer as admin and running the ide as admin just in case.

As an aside, I also have to turn off the McAfee real time scanning as it removes the loader. There isn't a way to tell it not to so has anyone reported it to McAfee to get them to white list it?

So anyone got any ideas for how to make the 101 work, or does it become an expensive inadequate paper weight?


Update on the issue spycatcher2k reported: My pull requests to fix all 4 of the incorrectly formatted Boards Manager files have now been accepted. If you have any 3rd party boards installed via Boards Manager I recommend doing the following before upgrading to Arduino IDE 1.6.11:

  • Tools > Board > Boards Manager
  • Wait for all downloads to complete.
  • Click the "Close" button.

That should ensure that you have the latest version of all the Boards Manager JSON files downloaded in case they have been fixed since your last download.

If anyone discovers another 3rd party boards package that's incompatible with Arduino IDE 1.6.11 please notify the author or report it here and I'll see if I can get it fixed.

I am still getting "An error occurred while uploading the sketch", same as with 1.6.10.


I still had boards 1.6.12 installed. Updated to 1.6.13. Now I'm able to upload the code.

More of a question for Pert...

1.6.11 running from unzipped location.

Boards version AVR currently 1.6.12 and it offers an update but when I go to it it still shows 1.6.12 as the latest.

Also getting a similar thing with a couple of libs.
Would rather not re-install as everything else is stable.

Is there a way to force the 1.6.13 package in and is it worth it ?
Or is there a way to just ignore the one package ? (apart from ignore the message)

I can't seem to reproduce this issue.

Arduino IDE 1.6.11 includes Arduino AVR Boards 1.6.13 so the problem is you have Arduino AVR Boards 1.6.12 installed to your Arduino15 folder from a previous IDE version. If you delete Arduino15/packages/arduino/hardware/avr and then restart the Arduino IDE it will force the Arduino AVR Boards 1.6.13 included with Arduino IDE 1.6.11 to be used. You can find the location of your Arduino15 folder at the next line after File > Preferences > More preferences can be edited directly in the file.

is it worth it ?

Definitely. The version of AVRDUDE included with Arduino AVR Boards 1.6.12 had some serious issues. They may not affect your current usage but if you do encounter them they will cause a lot of confusion and wasted time.

Also getting a similar thing with a couple of libs.

The libraries always show as updatable no matter what you do? I'm aware of this issue and how to solve it. Which libraries are they and which board do you have selected in the Tools > Board menu when you encounter the issue?

Very off but AVR 1.6.13 fix also seems to have fixed the libs issue at the same time in both IDE 1.6.9 and 1.6.11.

Knew if I asked the right person life would be better :slight_smile: