1.6.3 platform.keys.rewrite.txt

Good Morning

I was wondering what is the easiest way to not use platform.keys.rewrite.txt ??

I would like to keep using all the old path.

Thankz
Have A Great Day
ShorTie

Ok, been doing a lot of reading/research think I found in the revisions.txt a hint on how to do this,

"* platform.txt rewriting can be disabled if target platform has a "rewriting=disabled" key/value pair set"

But still at a lost how to implement this in the Linux32 platform.
If someone could Pleaze give me a little more info on how/where to implement this, it would be most appreciated.

Thankz
Have A Great Day
ShorTie

platform rewrites is triggered for custom cores only. what do mean when you say you want to implement this in the linux32 platform?

I am trying to get 1.6.3 to run on a raspberry Pi,
I have up to 1.6.2 running no problems using the system compilers.
With the addition of the platform.keys.rewrite.txt stuff in 1.6.3 I can not seem to get it.

I have tried hard coding then with

--- Arduino-1.6.3.orig/hardware/arduino/avr/platform.txt
+++ Arduino-1.6.3/hardware/arduino/avr/platform.txt
@@ -12,7 +12,7 @@ version=1.6.3
 # --------------------- 
 
 # Default "compiler.path" is correct, change only if you want to overidde the initial value
-compiler.path={runtime.tools.avr-gcc.path}/bin/
+compiler.path=/usr/bin/
 compiler.c.cmd=avr-gcc
 compiler.c.flags=-c -g -Os -w -ffunction-sections -fdata-sections -MMD
 # -w flag added to avoid printing a wrong warning http://gcc.gnu.org/bugzilla/show_bug.cgi?id=59396
@@ -75,9 +75,9 @@ recipe.size.regex.eeprom=^(?:\.eeprom)\s
 # AVR Uploader/Programmers tools
 # ------------------------------
 
-tools.avrdude.path={runtime.tools.avrdude.path}
-tools.avrdude.cmd.path={path}/bin/avrdude
-tools.avrdude.config.path={path}/etc/avrdude.conf
+tools.avrdude.path=/usr/
+tools.avrdude.cmd.path=/usr/bin/avrdude
+tools.avrdude.config.path=/etc/avrdude.conf
 
 tools.avrdude.upload.params.verbose=-v
 tools.avrdude.upload.params.quiet=-q -q
Index: Arduino-1.6.3/hardware/arduino/sam/platform.txt
===================================================================
--- Arduino-1.6.3.orig/hardware/arduino/sam/platform.txt
+++ Arduino-1.6.3/hardware/arduino/sam/platform.txt
@@ -10,7 +10,7 @@ version=1.6.3
 # SAM3 compile variables
 # ----------------------
 
-compiler.path={runtime.tools.arm-none-eabi-gcc.path}/bin/
+compiler.path=/usr/bin/
 compiler.c.cmd=arm-none-eabi-gcc
 compiler.c.flags=-c -g -Os -w -ffunction-sections -fdata-sections -nostdlib --param max-inline-insns-single=500 -Dprintf=iprintf -MMD
 compiler.c.elf.cmd=arm-none-eabi-gcc
@@ -76,7 +76,7 @@ recipe.size.regex=\.text\s+([0-9]+).*
 # SAM3 Uploader tools
 # -------------------
 
-tools.bossac.path={runtime.tools.bossac.path}
+tools.bossac.path=/usr/bin/
 tools.bossac.cmd=bossac
 tools.bossac.cmd.windows=bossac.exe

But that only seems to work for arm-none-eabi-gcc compiler.

I have tried adding the "rewriting=disabled" here and there also with no luck.
I see it is in the use for it is debug, does that mean i need to start arduino in a debug mode for it to work ??

Sorry, kinda confused right now after a long weekend of playing if that makes no sense.

Have A Great Day
ShorTie

FYI: here is how I get 1.6.2 to run on the pi which has worked since 1.5.6 by just updating a few patches.

http://www.raspberrypi.org/forums/viewtopic.php?f=66&t=92662

ShorTie please add some context to your experimentations with some verbose output. I've coded platform rewrite and I can tell you that if you change compiler.path to "/usr/bin/" it won't get rewritten. Rewriting occurs only when both key and old value are found in keys.rewrite file.

Ok, Me Sorry :sob:

Seems that my main problem was a corrupt file system on my sdcard.
The above patch does seem to work fine like you said it should.

With almost 4000 views of my thread over at raspberrypi.org,
I would like to give you folks a Big Thankz for all the hard work and effort you put into such a Great Program from all of us .. :wink:

Have A Great Day
ShorTie