1.6.5 R5 nightly build refuses to uninstall

I'm running Windows 10. I need 16U2 support, so I manually installed 1.65 R5 build. Now that 1.6.6 is available, I downloaded and ran the windows installer. It found 1.65R5 and offered to delete it, as is the normal behaviour when a new version is installed.

However, when I proceeded with that by affirming the dialog box, the installation ended without any further windows or messages. Just nothing.

So I manually deleted the Arduino folder from C:/programfiles/x86/ and removed the desktop icon. I then repeated the install. It still claimed that 1.65R5 was still installed and behaved identically (just closes without any further notifications or action).

I tried installing 1.6.5 with the windows installer. It gives the same message about 1.6.5R5 being installed.

I'm dead in the water.

Edit - you may wonder if I used the proper uninstall procedure to uninstall 1.6.5R5 (from Settings-Apps-blah-blah). The answer is yes. To the best of my recollection, it also failed to uninstall which is why I deleted the x86 folder manually.

Update - I was able to replace and run 1.6.5R5 (wshew!). But it seems I can't ever upgrade until this is solved. After replacing 1.6.5R5, I can see it in "Settings-System-Apps and Features" but the Uninstall button does nothing. I get one pop up, "The app and its related data will be uninstalled", but affirming that, simply closes the dialog. Nothing else.

I looked at the program folder again. It's all set to read only, so I thought that might be a problem. When I unset the read only by going through the dialogs and "apply" and "ok", everything seems alright, but when I go back and look at the read only attributes, they are still set! I can't believe it. I checked some other apps and it seems they are all set that way, so it seems that this is not really the cause of the problem.

The IDE now reports "1.6.6 Hourly build 2015/11/02 01:42" at the top screen! Perhaps R5 is a candidate for 1.6.6 so I guess it's normal.

What a mess. How can I clean it up and resume normal updates?

Update - I was able to manually install 1.6.6 from the zip file. I guess I can go on doing that as long as zip files are provided for new releases. It bothers me that there's still a hidden mess in my system that prevents normal updates from running. Also I found out that my file associations are screwed - I get an error when I try to open a .ino file.