12V DC motor burn Arduino through Grove Motor Shield

12V DC 21W motor was powered through the Grove Motor Shield on Arduino. Motor Shield max output is 2A External Power Supply is 12V DC adapter with 1A goes through Motor Shield It was working fine, but now Arduino cant acomplish simple tasks like blinking 13led I want to find out what was wrong, is the motor too powerful or it was OK, just ocasion that Arduino got burn? What motor is optimum for this task? (I need to control rpm in the range 1000-8000) I am sorry if these question repeated or too simple, I just start to work with Arduino. Help me.

First off, when you tried to put back the blink sketch, did you remove the shield first?

Secondly, when you did your test with the motor shield, did you load a blank sketch into the Arduino (so that nothing would activate anything on the motor shield accidentally)?

Thirdly - do you have any pictures of how you connected the shield to your motor and the power supply?

Fourth - does the motor work with the power supply as-is?

Fifth - the L298 does have a small voltage drop; will your motor run with less than 12 volts (you typically want about a 14 volt power supply for a 12 volt motor and L298)?

Sixth - Did you follow the steps here:


...and what about the power jumper - how did you have that configured?

Oh, that is well structured question... =D 1. Yes, I tried blink sketch with and without motor shield 2. Yes, I load blank sketch and then during tests it was working fine for 2 hours 3. There is only 4 elements, 12V DC adapter, Arduino + Motor Shield, Motor (Motor Shield feeds Arduino) 4. Yes, motor works fine with just 12V DC adapter 5. Motor works at 4.5-15V 6. Yes, I used that source to make my first trial

Power Jumper configured to feed Arduino from Motor Shield For more details, when I load sketch from the computer it says that it is loaded, but RX TX lamps are lighted but don't blink. When I run program all led lamps lights and then start to fade by pulses and motor doesnt run. Arduino board heats. It happened when I was unpluging and pluging DC adapter