1620a

I have tried to get lcd "hello world" to work. I get white boxes on line 2.
I have resoldered lcd panel, different breadboards and different sketches. Ide is 1.67. I tried dht11.just blue screen. Tied 50k pot and resisters. And 2 different lcd panels.help please!
is there a verified sketch that works?

How can we tell what is happening without a program and circuit?

Please put your code in its own window as seen in other posts. This can be done by placing     [code]  and [/code]  around the code or use the </> icon. This makes it easier for others to read.

How to use this forum

Weedpharma

From 1.67 ide example.

Please note that the LiquidCrystal(...) constructor accepts all pins used. Edit that line to match the pins as you wired them up.

jeffp60:
From 1.67 ide example.

You want our help but expect us to search for the program?

Weedpharma

Hi,
We will need a diagram of how you connected the LCD Display.
Can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png?

Also a picture of your project so we can see how it is layed out.

Thanks... Tom.... :slight_smile:

Sorry, no I dont expect you to search. Guess what I'm asking is are these things notoriously wrong? I am using both schematics and diagrams. I am using ide 1.67. And robotlinking sensor starter kit and cd. I get alot of file not found errors. Sufficiently frustrated at this point to toss it. So far dual servo and blinking lights have worked.

jeffp60:

  1. what I'm asking is are these things notoriously wrong?
  2. Sufficiently frustrated at this point to toss it.
  1. No, but first timers' implementations are.
  2. Stop being dramatic.

jeffp60:
Sorry, no I dont expect you to search. Guess what I'm asking is are these things notoriously wrong? I am using both schematics and diagrams. I am using ide 1.67. And robotlinking sensor starter kit and cd. I get alot of file not found errors. Sufficiently frustrated at this point to toss it. So far dual servo and blinking lights have worked.

If you are getting errors from proven programs, you have done something wrong. We need to know what errors you are getting to help.

Post the compiler text.

Weedpharma

Found one that works. Again, I read a few posts that said you have to watch cheap kits. Well I found two broken pin wires. And seems that if I move center of signal wire on 50k pot I lose the white blocks. I'll move my program questions to correct spot