2.8" TFT worked and quickly quit

I bought an Arduino Uno board and the Elegoo 2.8" TFT Shield. I plugged them together. It just worked. Examples from Elegoo including graphicstest and displaystring worked great. Then I tried another example, also from Elegoo, tftpaintshield. It failed to recognize the driver, which came back with an ID of 101. I found the following hack in the successful DisplayString:

  } else if(identifier==0x0101)
  {     
      identifier=0x9341;
       Serial.println(F("Found 0x9341 LCD driver"));
  }

Tried applying that to tftpaintshield. When I ran it it got as far as printing its introductory string, "Paint!"… And then NOTHING ELSE HAPPENED. No graphics.

Went back to the graphics-only examples that had worked before, and graphicstest now displays all the normal benchmarking output in the serial window, but NO GRAPHICS. The display screen remains white.

Okay, so what did I confuse, what did I break? I have tried:

  1. Power cycling/disconnecting the Arduino board
  2. Pressing reset on the Arduino board
  3. Stopping and restarting the Arduino programming interface app.
    Nothing helps.

There was no unplugging of the shield from the Arduino board, no funny touching of electronics that would be likely to cause any harm.

Any ideas? Do I have a defective part that failed rapidly under test?

Thanks,
Ken