2 days straight and HC-05 hates me

I have spent probably 20 hours + trying to figure this out with no avail.

I am new to Arduino, I got Arduino to build a RC toy tractor following the youtube build by rctractorguy but i wanted to use my phone for control instead of building a controller

I bought unos (several) and 3.3v mini pros from ebay.

I bought xbee bluetooths master/slave hc-05 from http://www.ebay.ca/itm/321512303393

my phone sees the HC-05 and can pair with it.

How ever no matter what i do I am unable to enter AT mode. with sketches i found online and how to connect. I get Enter AT Command at 9600 baud yet will not respond and I get ××Ø×Ø×××€×€××××€Ø×Ø×ØØ×ØØ××Ø×€×€×Ø€×€ at 38400 baud

I tried XCTU as well. It constantly tells me to reset. of which i tried several times either reseting the board or resetting the xbee by touching rst and grn.

I have hooked up the uno to the bluetooth xbee hc-05 using a keyes xbee shield and breadboard. with vcc to the 3v3

I have hooked the hc-05 to a fundino xbee usb adapter http://www.ebay.ca/itm/Arduino-BTBee-Bluetooth-Bee-USB-to-Serial-port-Adapter-FT232RL-Compatible-Xbee-W-/221568478918?hash=item339682aec6

I have tried to use Sena BTerm to access the bluetooth as well

all of these no luck.

There are two led's on the top of the xbee bluetooth the led2 is always on. the other i have never notice blink, flicker, or light up.

I tried XCTU as well.

Did you try Excel? PowerPoint? X-CTU is to configure XBees. You don't have XBees.

I get Enter AT Command at 9600 baud yet will not respond and I get ××Ø×Ø×××€×€××××€Ø×Ø×ØØ×ØØ××Ø×€×€×Ø€×€

That suggests that your bluetooth device is NOT operating at 9600 baud. Why do you think it is? Try other baud rates. Most bluetooth devices operate at 115200.

well on ebay it says the default is 38400

I am sorry for my naivety as it does say XBEE on the packaging.
Why would I try Excel or Powerpoint unless you are just trying to tell me that the wrong program is the wrong program no matter what you try to do.

I am just doing what others are teaching and trying to find the right answer.

I went into the script and changed the serial begin numbers and the myserial.begin numbers to other bauds and baud rangers. I get a response from the Monitor but again nothing legible.

This code allowed me to see Enter AT commands: under the serial monitor but it is still unresponsive to even AT

#include <SoftwareSerial.h>

SoftwareSerial mySerial(10, 11); // RX, TX

void setup() {

Serial.begin(38400);

Serial.println(“Enter AT commands:”);

mySerial.begin(38400);

}

void loop()

{

if (mySerial.available())

Serial.write(mySerial.read());

if (Serial.available())

mySerial.write(Serial.read());

}

Forget about AT mode. You don't need it to start with and may never need it. If you are running at 38400 it might be wise to forget about software serial too.

Google npyner bluetooth guide. It might be helpful.