2560 Mega Faulty

Hello, my arduino mega wont respond at all. Ive downloaded the software and installed the drivers. Im running wdws 7. The arduino green light is on but so is the orange light which flashes rapidly. Ive tried running the Basic "Blink" program but there is no response. Not sure what to do now. I wonder if it is faulty ?

No replies yet. Does anybody have any advice ? Should the orange light be blinking all the time ? Is there a test I could try ?

Does the mega show up under Device manager on the PC?

Is it the real deal or a China clone?

Hi there yes its there on Com4 and the driver is 1.2.2.0
Its a genuine Arduino, it says Arduino Mega on the board and has a gold coloured chip next to the USB port. I tried doing an update driver but windows says the correct driver is already installed

Roadtoad:
Hi there yes its there on Com4

And did you select this port in the IDE? And did you select Mega there as well? Assuming there is no ! in device manager.

It works. It was set on the wrong Com Port once I changed the port I ran the blink program. I was expecting some instructions with it but none came. Thanks for the help