2560 upload hangs; L-led blinks / No RX,TX blink

Hi there, I used Arduino Mega 2560 for while and it worked without a problem. After the following scenario I can not upload to it any more.

  • Connected Arduino to my computer by USB (Windows 7)
  • Upload a sketch which has something to do with USB Host controller port
  • Connected the 12v power adapter to Arduino
  • Connect de Vin to V5 on Arduino (Why did I do such a stupid thing? Because the USB host controller got its power from their, and I only connected a simple optic mouse to it)

The computer still recognizes the Arduino, the com port is available. But while uploading it hangs. I can upload the same sketch to an Arduino Uno, and I have tried all the same stuff on another computer. I have bought a new Arduino mega 2560 already, but if the old one is fixable that would be great!

  • The L-led blinks quickly at startup/after reset for 3~4 times.
  • No connection with serial monitor, when I send text no RX/TX blink.

Any help would be great.

PS. I searched the forum but none of the found topics where having the same issues.

Thanks!

Just to clarify: you connected 12V to the 5V rail? If so its pretty much guaranteed to be toast.

hi im not an expert in repairing these at all but if you have done what was suggested in the last post, 12v into a 5v connection you have more than likely toasted the arduino, theres a few examples on instructables.com (maybe on here as well) and on the internet on how to test and repair cooked arduino's.

you need to have a basic soldering ability, the ability to use a multimeter and some other general electrical skills to repair an arduino normally, so if your not sure id suggest trying to find someone who can look at it for you.

id start with buying a new Atmega chip (same as the one you have on that board, make sure it comes with the arduino bootloader already installed on it), if it works after replacing the chip, count yourself lucky and learn from this lesson.

if its still dead get the multimeter out and start testing the voltage regulator on the arduino, it should provide 5v, if its not replace it (this is where your soldering skills are tested). once replaced try again, if its still dead, then im affraid im out of ideas on what else could be the problem.

hope this helps though.

Kris

You need more than "basic soldering skills" on the Mega 2560!!!!!

MarkT: You need more than "basic soldering skills" on the Mega 2560!!!!!

ok scrub my comment about replacing the chip, its my fault should have googled the board before engaging my mouth on the forums lol.. im a fairly proficent solderer but im not even daring enough to go near surface mount chips :(

I read the hardware specs again, and again I think, why did I do such a stupid thing. And yes the 12v power adapter connected to Arduino was connected to V5 by Vin.

SO NEVER CONNECT Vin TO V5 IF YOU HAVE THE POWER ADAPTER ATTACHED!!!

Stupid mistake, with programming you just restart, or fix your code, with hardware there is actually some damage. I have to think about that more before trying some stuff.

Atleast it is not as bad as leaving your chair in the Large Hadron Collider while attempting to accelerate particles ;)

Thanks for the confirmation, I guess I hang the board somewhere on a wall...