3.3V Pro Mini not uploading sketches via SparkFun FTDI Basic Breakout

I was able to upload and run programs to my Arduino Mega 2560 with no problems while prototyping, but when I connected my Pro Mini to my SparkFun FTDI breakout board and hooked it up to my computer, I would get this error when it attempted to upload my sketch:

avrdude: stk500_program_enable(): unknown response=0x41
avrdude: initilization failed, rc=-1
Double check connections and try again, or use -F to override
this check.
avrdude: stk500_disable():protocol error, expect=0x41, reap=056

I'm using windows 8 and did change my board selection. I can see the TX and RX lights blinking when I first connect, and the green LED on the mini blinks about 8 times. The red LED on the mini is on constantly. Also, nothing is connected to the pro mini except the breakout board, and I did go through the troubleshooting steps on this website...

When I attempt to upload, the green on board LED blinks a few times and I see the TX and RX lights blinking as well. Then they all stop, except the red LED remains on.

No idea what is going on. Anyone out there know how to fix this?

Also on the bottom of the window I can see this displayed
Arduino Pro or Pro Mini (3.3v.8 MHz) w/ATmega328 on COM5

I tried two other mini USB cords and the third one allowed me to upload. So problem solved. I was not aware there were different types of mini usb cables??