3.5” Kuman LCD mounted on Screw Terminal Breakout Board not working

I recently purchased a Kuman 3.5” LCD and got it working when it was directly mounted on an Arduino Mega 2560. All of the LCD and Touchscreen examples from the LCDWiki site worked fine. I haven’t tried any SD card examples. That is for the future. What I want to do is mount the LCD onto a screw terminal breakout board that is then mounted on the Mega. In this manner, I have better access to all of the Mega connections that I need for other purposes. However, when the LCD is directly mounted on the breakout board, and the breakout board is directly mounted on the Mega, I only get a white screen, even when using an external power supply. What is more puzzling is that the LCD works fine when it is directly mounted on the breakout board, but uses jumpers between the breakout board and the Mega. To isolate the problem, I’ve disconnected all of the other stuff from the breakout board. Further, since I was only using jumpers from the pins associated with the LCD, I thought there might be interference from other pins. I haven’t tested with every pin jumpered between the breakout board and Mega at the same time due to the limited number of jumpers at hand, but have tested groups of pins. In every case, the LCD examples worked fine, even after having used jumpers on all available pins (just not all at once). Am I correct in assuming this is a hardware issue given that the examples worked when using the jumpers? I have run out of testing ideas and could use some guidance. By the way, I’m pretty new with this stuff.

As you describe it all suspicion goes to the breakout board. Any cracks or imperfections?
From picture #2 I note that this 3.5 inch TFT can also be mounted directly onto an Uno.



No cracks that I can find. I also couldn’t find any shorts between pins, despite my mediocre solder job.

I’ve also minimized the number of jumpers between the Mega and screw terminal board (basically, GND, 5V, A0-A4 and D2-D9). Everything works fine provided the screw terminal board is jumpered to the Mega regardless of whether or not the LCD is mounted on or jumpered to the screw terminal board.

This doesn’t make sense because the screw terminal board doesn’t appear to have any circuitry other than a reset button. Is there any chance that my problem is the reset button? Is so, I could try removing it.

BTW, Yes, this LCD will mount on a UNO, but my project includes 4 servos, 2 mechanical grippers and an as yet indeterminate number of optical limit switches so I need lots of I/O pins.

Problem solved. It turns out that a number of pins on the screw terminal board were not making electrical contact with their corresponding sockets on the Mega.

Do you mean to say they were bent?

The pins all looked good, and straight, but at least a dozen had not made contact within the female headers. I needed to check every pin with an ohm meter from under the Arduino to the top of the screw terminal shield looking for non-shorts, then remove the shield, angle the pins, reattach and recheck. I must have gone through a dozen or more of these tedious steps before ensuring that all pins made good contact.

I’ve now reconnected the motors, switches, etc., and am now debugging new gremlins that worked fine beforehand.

Hopefully in the next day or two I’ll be able to move forward with the SD card reader and limit switches.