3 Nanos, 4 I2C devices, 2 IDEs... I2C Not Working

Hi guys !
I’ve got 3 nanos (clone) and 4 i2C devices (2 BMP180, 2 OLED 32x128), but still, after trying everything, from changing IDE to multimeter tests, I’ve still got issues.
None of my nanos / i2c devices recognized themselves. Every ones used to work a week ago. Tested multiple ways.
I’m using this code to find i2c, nothing gives (No devices found)

// I2C Scanner
// Written by Nick Gammon
// Date: 20th April 2011

#include <Wire.h>

void setup() {
  Serial.begin (115200);

  // Leonardo: wait for serial port to connect
  // while (!Serial) 
  //  {
  //  }

  Serial.println ();
  Serial.println ("I2C scanner. Scanning ...");
  byte count = 0;
  
  Wire.begin();
  for (byte i = 1; i < 120; i++)
  {
    Wire.beginTransmission (i);
    if (Wire.endTransmission () == 0)
      {
      Serial.print ("Found address: ");
      Serial.print (i, DEC);
      Serial.print (" (0x");
      Serial.print (i, HEX);
      Serial.println (")");
      count++;
      delay (1);  // maybe unneeded?
      } // end of good response
  } // end of for loop
  Serial.println ("Done.");
  Serial.print ("Found ");
  Serial.print (count, DEC);
  Serial.println (" device(s).");
}  // end of setup

void loop() {}

For BMP180 and OLED display, I use the provided examples (which worked earlier)

I’ve no idea what’s doing it. I tried with Create.Arduino.CC, with the offline IDE (it could have been a library issue with the offline IDE, as I’ve been messing with duplicates around projects).

I’m wiring my (5v compliant) i2c devices right, SDA to A4, SCL to A5, GND well, VCC to 5V
None of the pins are shorted

Thanks a lot

EDIT : Wired on Breadboard, I’ve tried with USB, and an external 5V supply (bb supply)
EDIT 2: everything else works; pins A4 and A5 are usable as outputs fine. Uploading is OK. Only I2C is messing up

Pull-up resistors?

Why ? aren't those included with the usage of I2C in the nano ? It used to work without the addition of any

EDIT : Seems that Wire sets the A4 and A5 as internal pullups at startup (see I2C with internal pullups - Networking, Protocols, and Devices - Arduino Forum)

I don't know. I2C is supposed to have relatively low-value pullup resistors. Sometimes they are built into the devices (perhaps with jumpers), some times (maybe) the internal pullups are enough, but having them missing would be something that caused randomish behavior...

I may try setting the pins to INPUT_PULLUP after starting Wire.

Well, today, pluging in the Nano (not even uploading the sketch I just wrote to test with INPUT_PULLUP) and eveything was back to normal. Weird things, maybe divine intervention ? LOL

[thread resolved]