3020 timeout after 400ms

Just a few days ago I had no problem running the Arduino editor with my chromebook but all of a sudden the past two days every time I try to upload to my Sparkfun Inventors Kit redboard I keep getting this error. Can anyone help?

Sending 3020: receiveData timeout after 400ms

There have been some issues since Friday. The team are back in the morning so hopefully they will catch up with those and yours will be fixed too.

Hi @frogballet,

Unfortunately, the Sparkfun Redboard is not one of the boards officially supported by the Arduino Create Chrome app (for a full list please see: http://forum.arduino.cc/index.php?topic=465962.0).

Some suggestions:

  • Try a different USB cable
  • Try loading a sketch from a non-Chrome OS based PC using Create and/or the regular IDE
  • Try pressing reset from before the sketch starts uploading.

We have been experiencing the same error when trying to upload the blink on a Nano but selecting Uno from the Select Board modal. @sandeepmistry you can try to reproduce like that maybe

How is this still such a big issue? Running into it with an Arduino UNO here...

Hi there,

We've tested with the Uno again on both the Chrome OS devices we have access to and have not encountered the issue.

Could you please provide more info?

  • What version of Chrome OS are you using? chrome://version
  • What Chrome OS device are you using
  • Was this working previously? Does upload work intermediately?
  • Does this issue appear when a particular sketch is load?
  • Do you have access to a non-Chrome OS PC to test if the Uno is functional

I am currently having this same issue with the new Arduino Create for Education App with our student's Dell 11 Chromebooks.

We are using: Version 63.0.3239.140 (Official Build) (64-bit)

It was working previously on Macs before we switched to the Create for Education App on the Chromebooks. It does upload at first, but then the error happens and it will not upload after that without changing Arduino boards

One of the sketches we are using is: https://create.arduino.cc/editor/dan_bell/737f2abe-d3be-4aee-a5f0-ef05a88ef8ac/preview (it's for the Adafruit Neomatrix light boards).

Hi @dan_bell,

Are you using an Uno board? Is the Neomatrix plugged in during sketch upload?

@sandeepmistry

Yes to both.

Again, we’ve recently switched from the CPU-based IDE on MacBook Pros to the Create for Education App and have changed nothing else. It usually uploads normally to the Uno once or twice before this error occurs.

@dan_bell would you be able to try again without the Neomatrix connected, I'm wondering if the Chrome OS devices might not be able to supply enough current over USB?

@sandeepmistry

We've actually also tried with the Uno's plugged in with a separate power source. We still get the error message.

@dan_bell thanks.

I’ve been able to reproduce the issue here, but only when the Serial monitor of Create is open and I quickly load a sketch right after the other. I’m not sure if it’s the same scenario as what you are hitting.

Do you have the serial monitor of Create open when loading the sketch by any chance?

@sandeepmistry

We don't have the serial monitor open when we get the error. Thanks so much for looking into this for us.

There will be a new v1.0.11 release on the Chrome Web Store today, which includes fix for this if the serial monitor was open during sketch upload and sketches were uploaded quickly.

@dan_bell I don't expect it to solve the scenario you are seeing, but let us know. Also, if you refresh the Arduino Create page, does the issue still occur?

@sandeepmistry

Yes, students do still experience the issue after refreshing the app/page.

I did see the new version for Arduino Create on the Chrome App Store, but we are using the version for education, which is pushed out to us via our Google Admin. Is this version of the app updated as well? Would we need to have it reinstalled by our admin to update?

3020 timeout after 400ms

Getting the above error continuously using Dell chrome book and genuine UNO r3. Even on one bought this week.

Found a work around.
Close the monitor window.
re-select the board from the drop down menu.
It displays slightly differently. Shows the first letter of the port assignment.
Upload sketch.

After work around I now find that Monitor does not work.

@sandeepmistry

At least 30-40% of my students per class are still getting this error on their Chromebooks. Today, though, a student thought to login to their create.arduino.cc account on one of our Macbook Pros and, after I installed the plugin, things started working smoothly. I tried this with several other students who were having the same error on their Chromebooks and it worked for all of them.

So it does seem to be a Chromebook-specific issue. Again, we are using Dell Chromebook 11 generation 2 Chromebooks.

mine still won't work

Hi everyone,

We still have not been able to reproduce this condition with our Chrome OS devices.

Could you please:

1) Open chrome://extensions 2) Click "Inspect views: background page", then click the "Console" tab 3) In a separate tab, open Arduino Create 4) Load sketches until you see the error

After step 4) please share a screenshot of the window opened in step 2.

Also, please let us know if there are any other Chrome apps that are installed on the devices, and if they also might use any serial ports.