5.0" CTE no touch?

Hi All,

I'm onto my 3rd 5.0" CTE display and still not having any luck with it and the UTFT libraries, getting a bit frustrating as I just want to get on with my project.

This particular display is the CTE running the CPLD chip. I'm trying to get uTouch running though it appears as if getTouch is only reporting a few different combinations of X,Y regardless as to where my finger is on the screen.

This is the output of 3 lines with 3 touches each from left to right, top to bottom: X:0 Y:0 X:-1 Y:-1 X:0 Y:479 X:0 Y:0 X:0 Y:0 X:342 Y:479 X:799 Y:0 X:799 Y:479 X:799 Y:479

I've initialised the display as: UTouch myTouch( 6, 5, 4, 3, 2);

My calibration file is:

define CAL_X 0x03FFCFFFUL

define CAL_Y 0x03FFCFFFUL

define CAL_S 0x001DF31FUL

Though I've tried others to no avail. Any ideas?

I have a CTE 5" CPLD display, and a CTE TFT shield for DUE, and Sainshit TFT shield for MEGA.

My display is fine and touch is fine, on both platforms, with both shields, using UTFT and UTouch.

Specifically, what problems are you having with what hardware?

Regards,

Graham

Just an observation, but that cal figure is not even close to what it should be...

// CPLD MEGA
#define CAL_X 0x00108FCFUL
#define CAL_Y 0x03BE40CBUL
#define CAL_S 0x8031F1DFUL

// CPLD DUE
/* #define CAL_X 0x000CCFD7UL
#define CAL_Y 0x03B940B5UL
#define CAL_S 0x8031F1DFUL
 */

And when you get a set of figures......... check them using Henning's checking tool.

http://www.rinkydinkelectronics.com/t_cal_verify.php

Regards,

Graham