5V Pin overloaded?


so I have a problem with my project with I cannot seem to solve alone.
I have a Nano with multiple things attached, a Pump via a Relay, a 1.77" TFT Screen, Humidity and Temperature Sensors as well as a moisture Sensor and last but not least a Ultrasonic sensor, which is problematic at the moment.

The Ultrasonic sensor is constantly reading 0 as distance while all the other Sensors and the Screen (which I run off 2x 5v (instead of 3,3V for the backlight, it was too dim!) work perfectly fine.
It all worked fine until this morning and I don't know what I changed. The wiered thing is that when I unplug the 5v vcc from my TFT screen, suddendly the Ultrasonic sensor reads 16 cm, which is not exactly right but close to being it. As soon as I plug the 5v vss pin back to my + line on my breadbord the sensor goes back to 0 values. As I said, other Sensors work fine and this one did aswell until now.

The Nano has only 1x 5V and 1x 3.3Volt pins. I don't know anything about current so I am thinking maybe I cannot draw enough current from that single 5V Pin to provide current for 8 consumers..

I have one pin from 5V to my positive line and hooked the rest up on the line itself of the breadbord exept one connection wich goes to my Screen VCC, hooking it up to the + line doesnt cut it. Maybe the Jumper wire between arduino and + line is the bottleneck?

Thank you for any help, I have no Idea what I am doing...

Edit: I shoud add that I am powering the whole thing with one USB atm.

Edit: I shoud add that I am powering the whole thing with one USB atm.

What is "one USB"?

The idea of powering a Nano with regulated 5 V through the USB port, such as a "Phone charger" which nowadays are rated up to 2.1 Amps, and then other things from the "5V" pin is limited by the capability of the diode between the USB socket and the "5V" pin. And you lose voltage in the diode.

It is better to just get your 5 V supply - such as your "Phone charger" - and feed it in parallel to the "5V" pin as well as the other devices requiring 5 V. You just need to arrange the appropriate connector to the Phone charger.

Hi All,
The Vss input is for a negative voltage (or
ground if you do not have negative).
Maybe that is the problem?

Hi! No, its VCC and that is for +, since there is another pin called ground which should probably go to ground :smiley:

Welcome to the forum.

Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html . Then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

Can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png?

We need these two items so we can give you better answers.

Thanks.. Tom.. :slight_smile:

Hi again!

I am sorry for my very poorly drawn circuit but since it is a big mess of jumper wires, a picture would have been impossible to decript. So I have drawn a circle (1) arround the LEDA Pin of the Screen. When I unplug that one, all of a sudden the Ultrasonic sensor reads good and accurate values. When I plug it back in, it reads constant 0.

My code should be fine, probably no need to attach it.

VCC of the screen is plugged in under the 5v pin because somehow its not working when I plug it in to the + strip on the breadboard.

I really am new to this thing and have no Idea but as far as I know Current cannot be lost, its only the total power draw which can be exeeded? So I have tried pluging in a double usb cable whoch should be capable of 1 A (2x500 mA) but that doesn’t change anything. Also, unplugging any other 5V consumer doesn’t fix the Sensor.

Note that the LEDA Pin should acctualy be plugged in the 3.3 V output but first of all it makes the display go increadibly dim and secondly it doesn’t fix my readings.

Any Ideas?
Thanks in advance!

OPs diagram.

Thanks.. Tom.. :slight_smile:

I should also add that I tried connecting + Strip of the breadboard with a second jumper wire to the 6V Pin thinking the single jumper cable could be the bottleneck but that did not help. Also, spreading the connections to 5V between the two + Strips of the Breadboard didn't help either.

I my eyes there can only be two reasons: Either the 5V Pin is somehow too weak and I would need a bigger Arduino with 2 or more 5V outputs, OR

My Powersupply is too weak as in the USB cable cannot power everything. I have a powersupply module for that breadboard but not the cables to connect that thing to power. Its called Elegoo Power MB V2. Maybe that can power everything however I don't know how to use it. How would the Arduino itself get the power it needs? That Power Supply Module only powers the + and - Strips of the breadboard, right?

I also tried powering the Arduino on my 5V smart Phone charger rated up to 2,4A. That did not change anything.


Do you have a DMM?

Tom... :slight_smile:

Hi Tom! Thank you for helping. No I don't have any Electrical Equipment, no Voltmeter, Multimeter or anything honestly. Believe it or not, I don't even own a screwdriver! I had to turn potentiometers with the pointy end of knifes... Thats how little equipment I own.


Suggest you invest in some basic hand tools and an inexpensive DVM.

Not doing so will just result in no end of frustration on your (or maybe our) part.

That might be true.
Lets say I had one, what would I be looking for, what Values would be wrong and which would be right? A Friend of mine is an electrician, he has the tools for sure. Do I need to measure the current on the 5V + Strip?

So noone has any Idea what could cause the problem. I asked arround myself and litteraly noone has a clue. Great. I am running out of Ideas...

Go and buy a multimeter. You cannot continue in this hobby without that one tool. A $3 one is all you need. Don't get fancy and spend more than $15 (or your local equivalent currency.)

You may see really cheap "voltage testers" that just light up a light with 12V. That is useful to an automotive technician but not useful to you. You must get something with numbers on it.

Go and buy a multimeter. You cannot continue in this hobby without that one tool.

Amen to that. Pack up and take up knitting until you get it.

A $3 one is all you need.

Now that is extreme. I have not seen them advertised under US$4.50! :roll_eyes:

It is really annoying that you cannot get rid of those "$xx to $yy" rubbish postings on eBay! :astonished: