74HC595N shift register not working

Hi, I couldn't find anything about this unfortunately, or nothing that seemingly solves my problem so here it goes:

today I bought 4 "74HC595N" shift registers and I hooked up the arduino as in the shiftOut() tutorial, used the same code, but it doesn't seem to work. :frowning: I've tried all of them, I guess it's not the products fault, I must be missing something. Do you have any advice for me? Thank you very much in advance!

(on the picture the unit is facing to the left)

Image: Imgur: The magic of the Internet
Datasheet: http://www.ti.com/lit/ds/symlink/sn74hc595.pdf

Very hard to tell in that photo where the wires go.
Specifically the two orange wires.

The 595 has 3 main pins:

  • data (595 pin 14, called SER or DS depending on datasheet)
  • clock (595 pin 11, called SRCLK or SHCP depending on datasheet)
  • latch (595 pin 12, called RCLK or STCP depending on datasheet)

The /OE signal (pin 13) is the only pin from 595 pin 9 to 16 that needs to be grounded.

I can't figure out what other 595 pin you are grounding - but it shouldn't be needed.

Hopefully it is not a 595 pin that is also connected to an Arduino pin.
If so, it might burn up the Arduino pin from creating a short since it is grounding the Arduino pin and the sketch will by trying to drive that Arduino pin.

If you could explain what is connected to each pin on 595 pins 9-16 and then show the code you are using it should be pretty easy to figure out what is going on.
--- bill

Thanks Bill!

It worked, I just disconnected the second ground wire and it solved the problem. It seems like fortunately it didn't burn the arduino pin as it's still working.

You are the best!

-David