A fatal error occured

So I've been trying to set up a esp32 camera ,Tried doing a more advance code and getting this error
A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header.
Now I'm just trying to do some simple code just to trina solve the problem.
I already change the esp32 cam module,bought another ttl to usb connector and tried multiple usb cables.
This is the error code below
Arduino: 1.8.16 Hourly Build 2021/09/03 10:33 (Windows 10), Board: "AI Thinker ESP32-CAM, 240MHz (WiFi/BT), QIO, 80MHz"

Sketch uses 224185 bytes (7%) of program storage space. Maximum is 3145728 bytes.

Global variables use 11884 bytes (3%) of dynamic memory, leaving 315796 bytes for local variables. Maximum is 327680 bytes.

esptool.py v3.1

Serial port COM1

Connecting......................................_____

.

Before uploading the sketch, you pressed the ESP32's cam reset button correct? And that caused the monitor to display a 'waiting for upload' message, correct?

If the waiting for upload message does not appear then the upload will fail.

Yeah I've pressed the reset button>But it didn't display any waiting for upload message.

That would be a problem. Can you post a image or 2 or 3 of your project all hooked up to the FTDI thingy and post a link to your FTDI thingy. I found some ftdi thingies work work and others do not.


Also tried switching from 3v to5v on both my modules. This is the exact thing https://www.amazon.com/HiLetgo-FT232RL-Converter-Adapter-Breakout/dp/B00IJXZQ7C

Hi @falconds

Try this way:

RV mineirin

tried it still the same error

I got several of those modules (from post 5), I did NOT get them to work with the ESP32-CAM.

HiLetgo CP2102 USB 2.0 to TTL Module Serial Converter Adapter Module USB to TTL Downloader With Jumper Wires are the modules that worked for me with the EPS32-CAM.

Pretty sure they aren't the same models
https://www.amazon.com/HiLetgo-FT232RL-Converter-Adapter-Breakout/dp/B00IJXZQ7C

Everyone on youtube who does tutorials has this adapter

COM1 is usually the computer's internal serial port. Please run this experiment to determine whether COM1 is actually the port of your FTDI FT232 adapter:

  1. Unplug your FTDI FT232 adapter from the computer.
  2. Select Tools > Port from the Arduino IDE's menus.
  3. Note the ports, if any, listed in the menu.
  4. Close the Tools menu. The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  5. Plug your FTDI FT232 adapter into the computer.
  6. Select Tools > Port from the Arduino IDE's menus. - The new port listed in the menu is your FTDI FT232 adapter.

That seems to be the problem . But no matter what I do only port COM1 shows image

Not sure if this helps but when I connect the esp32 cam and try to get a signal from the reset button nothing shows up

If COM1 is listed on the menu even when the FTDI adapter is not connected to your computer, then COM1 is not the FTDI adapter.

This is normal and expected if COM1 is not the FTDI adapter. Stop fiddling with COM1 and focus on getting the FTDI adapter to be recognized by your computer.

Open Windows Device Manager and then connect the FTDI adapter to your computer. Do you see a new device appear in the Device Manager device tree?