A noob with a noob question

Hia! Got my first arduino (uno) today, never used this, or done any programming before. The problem I am having is that when I disconnect the board from my computer, it forgets the programming. I have 8 leds connected goin in a pattern, but as soon as I disconnect and reconnect the board, the programming is lost, and I have to re-upload it. Isnt there any onboard power on the board? Thx

It has happened to me a few times. Simply rebooting the MCU itself should work, by pressing the restart button for example.

as soon as you re-apply power

As soon as the bootloader times-out. ;)

I vaguely recall that there is a bootloader bug that can cause this problem. I believe the problem and solution was discussed recently in the forum. If searching doesn't produce a result, reply and I'll try to find the thread.

thx for the responses, yeh, tried searching the forum, couldnt find anything relevant, so I made this one :) I tried pressing the reboot/reset button on the board, nothing happens :(

http://arduino.cc/forum/index.php/topic,38002.msg281498.html#msg281498 http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1295516707/0#2

Here is the posting for fixing the Uno bootloader:

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1295516707

Lefty

Edit: Drats, beaten by the dastardly Coding Badly once again. ;)

Before Optifix came along, I reflashed my Uno to use the Duemilanove bootloader, I had so many problems with it. Now I've reflashed my Duemilanoves and Uno with Optifix, for the benefits it offers. (Somewhat confusing setting a Duemilanove as a Uno in the IDE, but its worth it.)

Thank you so much for all the answers, but I cannot get this to work (yes I know, Im a noob). I tried installing the optifix scetch by uploading it to board, didnt work. I also tried installing optiboot, but did not find the Uno card in the hardware section.. I know Im prolly doin somethin wrong, just dont know what it is. Thx for ur help

Still unable to find any solution. HELP PLZ! :P

Do you have an SMD UNO?

Does this help... http://arduino.cc/blog/2011/01/20/issues-with-the-new-arduino-uno-smd-edition/

Yes, this might very well be the issue. But I am unable to find the serial on my card, and I really do not understand how to fix it :P I also dont want to return the card, since it was sent from canada, and Im in Norway.

Anyone that can write a simple to understand turtorial on how to reflash the new bootloader to fix this problem ? :)