A problem when importing 3rd-party libraries

I want to write my skech on “Arduino Create” and my project need a library called SCoop, but it can’t be found by the search, so I downloaded a .zip file on the github and was successful importing it into my custom lib, but I still can’t Verify my sketch for “No such a file” reason. I want to know how to solve this problem.

Some third party libraries might not import correctly as they may contain things the editor does not like.

Attached a help file for importing libs and sketches.

There may also still be a folder depth limit in CREATE so sometimes you may need to remove excess folders.

Importing sketches and libraries.pdf (285 KB)

I don't think I did sth wrong so can u just help me zip this libraries into the form I can directly import? SCoop library: https://github.com/fabriceo/SCoop

I probably could do the work for you but then you would not have learned anything.

May I suggest you use the help file provided and come back when you are actually stuck with doing that.

Noticed also from your other post you may be using ESP8266 so I must ask what board this problem is actually with ?

Sorry for a long-playing scilence! And thank u for ur consideration!
Now I deleted some files (leave only 1 library I need) and things goes like this but still can’t work.



(I attached the zip I imported below)

Just Aruino UNO used in the project!

SCoop.zip (32.6 KB)

The original files import perfectly from your github link. They show up in CREATE just fine.

Almost all the examples compile just fine apart from 3 in the whole range of examples and they throw an ARM/AVR type error and refer back to the Arduino forum but nowhere in particular !

It might be better if you contacted the author on GITHUB as I also noticed many parts are over 6 years old ! EDIT here is the authors original post about the lib

The original files import perfectly from github link.
But still can’t find SCoop.h

I think it’s because this lib is already mature(actually it is I think). So there is no need to update it.
Can u just upload the zip which can work properly? I WILL check the diffrence and find why. (I think this can help me in a more direct way since I don’t have enough time to read such a long .pdf)

As I already said the original link you gave imports just fine !

Nobody ever did my work for me.

If you are not prepared to help yourself by doing some reading at the very least then I don't see any point in trying to help further.

Tried again I can see the success info and can click INCLUDE botton and can even see the comment // SCoop - Version: Latest added, but can't access the complier still. Is this problem about the policy that in my country I can't upload it well(CN)?

I am unsure about it being your internet connection in China ?

However CREATE does also work with most VPN's if you have access to one ?

Also unsure what you actually mean by access to the compiler so if you could give more detail. Can you compile any of the example sketches ?

No I can't complie any sketches. I think this can explain my situation well: https://www.youtube.com/watch?v=ePRTo8p-vLM&feature=youtu.be

OK your video shows a "WINDOWS" screen and NOT a Chromebook device.

Please what are you actually using as your OS and browser ?

In your other post you state CHROME CORE did you just mean CHROME BROWSER ?

It's windows system and now it's none of the Browser‘s problem since I've change it into Chrome itself. But problems still happening: https://www.youtube.com/watch?v=9K-E0ZYaP6o&feature=youtu.be

Could you please try again but follow the steps below.

  1. Open CREATE normally.

  2. Remove the scoop lib from your custom libs.

  3. Refresh the CREATE editor page.

  4. Right click on the CREATE taskbar ICON and select “Open DEBUG Console”
    An almost blank web page will open and you should leave it open for the moment.

  5. Go to the CREATE editor page and import your lib without any changes to it.

  6. After the error shows up open the DEBUG page.

  7. COPY AND PASTE that content back here but ENSURE you use CODE TAGS ( </> )

  8. Close the debug web page

Maybe the log will show something as we have not yet been able to re-create the problem.

It was an error on our end. It should be solved now. Can you confirm?