A service installation section in the INF is invalid

While trying to install my Arduino UNO (rev3) on a Windows (Embedded) 8 machine using the new signed driver, I get the following error:
Windows found driver software for your device but encountered an error while attempting to install it.
Arduino Uno
A service installation section in the INF is invalid.

Any ideas? The old driver also gives an error, saying "The system cannot find the file specified."

I have tried various Uno boards on different machines. I even tried it on a virtualbox Win 8 Embedded installation that is running on my dev machine (on which the Arduino is working).
But I get this error every single time.

I've had the same problem on Windows 7 Embedded. I don't know if your problem have the same source but here is how I've solved it :

  • make sure that winemb-inf-mdmcpq.cab and winemb-inf-mdmcpq2.cab package are installed on your image. (if not you can find them in your Windows Embedded Distribution Share and install them on an online image with DISM.exe)
  • connect arduino UNO board
  • donwload arduino 1.5.5 BETA software (zip version) from here : http://downloads.arduino.cc/arduino-1.5.5-windows.zip
  • unzip it, go to drivers directory and launch dpinst-x86.exe (or dpinst-amd64.exe if your are using Windows 64bits)
  • ignore warnings about unsigned drivers and continue installation

I'm not using Windows 8 embedded yet, but I will in a near futur, so please keep me informed about results you get with this process.