A strange problem in terms of Modbus RS485

I'm using Arduino MEGA with SN65HVD08 RS485 serial interface to read Modbus registers (Float32) from a energy meter. I have tried different modbus libraries with very similar results.

The problem: Most registers are read correctly, but for some of yhem I receive invalid values, like [0, 65472], and I don't know why...

So far, with this Modbus bridge I have the best results, but not complete: GitHub - f1oat/LDuino: Ladder logic PLC software for Arduino - Compatible with LDmicro Ladder logi

Are the same register addresses ALWAYS giving an invalid value? Does this problem exist for all meters you have tried?

What are the proper values for the registers? Does the documentation have anything about why these registers are different?

Paul

Hi Paul, on different libraries, the same registers is giving invalid readings, but for invalid readings always the values of two 16bit registers is the same [0, 65472]. Also the router has an integrated Modbus bridge (Serial - TCP), the results are the same, I just want to be sure that it is not a problem with Arduino code