A thread for serious bugs in the new forum


I’ve verified it as well with other tutorials (not from me)


The behaviour only seems to happen when you use the copy button, not if you select the code and copy it.

That was my conclusion too but the problem needs fixing in a hurry. We have enough trouble with code being posted improperly without introducing new problems

Any thing in the works to enable editing of pre-discourse threads which have had their formatting ‘tinkered’ with by the new software?

@sterretje & @J-M-L we can’t reproduce this issue at all. We tried several combination of browsers / OS but we aren’t getting those stray \240 and \302 characters.

Can you tell us what browser and OS you are using?

What do you mean you can’t edit posts that were created before the migration?


@J-M-L 's code now seems OK. Try the first example in Serial Input Basics - updated, it still has the problem.

Browser Firefox 87.0 on Win10.


Thanks, I was able to reproduce with that one. Will fix.

1 Like

Can you tell us exactly what you tried ?

Use the copy button to copy code from a code box posted in one of the tutorial topics, paste it into the Arduino IDE and try to compile it

An example from Serial Input Basics

Windows 10
Chrome browser
IDE 1.8.13

1 Like

Thanks, I guess we tried on the wrong code blocks.

We are able to reproduce the issue with the one that @sterretje mentioned above.

I’m working on a fix. Hang tight.


I am glad you got there
Looking forward to the fix

The fix is cooking :shallow_pan_of_food:

Will soon be deployed here.

I will let you know once it’s available.

1 Like

Will the fix go through all the database of legacy post and be applied to all code blocks (if they were corrupted) or is it actually fixing the “copy” button so that it just takes the basic ascii text ?

if you go through all legacy post again, may be it would be good for the script to try to put the images back where they belong too and change the underline tags

(eg my state machine tutorial in French with 31k views looks ugly now, I don’t know what happened to all the images)

@J-M-L , @LarryD also lost lots of images in e.g. Share tips you have come across

I seriously hope they can be recovered and inserted.

The fix is making sure any weird white space character is replaced with a proper white space character when using the copy button.

I’m working on that. Images shouldn’t disappear.

Not sure what you mean by “change”, but underline is not supported in Markdown.


you mean underlining like this is not supported and thus impossible to type ? :slight_smile:

what I mean is that the [u]and [/u] tags that litter posts are looking ugly.

If you think they should not be applied, then change those into bold or just get rid of them. It makes the text cumbersome to read (but I would rather see my original work as it was since it’s technically possible)

[u]still works[/u] still works :slight_smile:

Too late, J-M-L already demonstrated

exactly my point

But not in the quoted text :roll_eyes: :roll_eyes:

corrected. interesting that Quote will get rid of the tags

Ok, the fix is now deployed :+1:

Thanks for reporting this issue.

I wasn’t clear. Markdown definitely do not support underline. But Discourse does support some BBCode tags.

Your posts look fine to me :wink: Except for the images, which I am fixing…

1 Like