A4899 Stepper driver problem

Hey,

I got an A4899 Stepper Driver trying to run a bipolar Nema 17 motor.

Motor is an "17HS19-2004S1" Datasheet

The A4899 is from ebay, dont know if its the 50mOhm or 68mOhm sense resitor version.

For the life of me, I can´t get the motor to run. It´s stuttering or doing whatever it wants. Everything is wired and coded as in the dozens of tutorials out there. Example I even got the filter cap for the supply voltage.

By now I´ve tried every combination of supply voltages from 8-30V with every current limit set with the poti. I´ve also tried a 2nd A4899 I bought, same behavior.

I´m getting the feeling I mismatched the driver and the motor but the values seem to line up for me.
Am I missing something?

Thanks

Its the A4988, not A4899.

That chip can't generate 2A which is the nominal current rating of your motor.

However if you set the limit to 1.2A or whatever is the maximum the A4988 can handle without thermally tripping, it should move the motor, albeit at less torque.

Perhaps you didn't check the motor pinout using a multimeter - its always a good idea to check the
windings are as you think they are.

You are using a sensible step rate?

For testing try this Simple Stepper Code

Plus what @MarkT has said.

...R
Stepper Motor Basics

Hey everybody,

the coils are and have been checked once by multimeter and once by shorting two of the four wires and feel for increased resitance when turning the stepper by hand.

I´ll see if I can get along with the reduced torque because of the current limit once I get it running. I think I shouldnt run into a problem here because its not a high load in my application.

I´ve tried your Simple Stepper Code, it´s basically the same as the one I´ve been using so far though. It doesnt work either.
I´ve read through the hole Stepper Basics and didnt find anything new I hadnt considered yet.

RST and SLP are shorted, the driver is powered with 5V via the Arduino, the coils are connected correctly, no microstepping, Step and Dir Pins connected correctly, tried motor supply voltages up to 30V.

Sometimes I get stutter out of the motor, or even a few degrees of movement, but never the intended behavior.


I´ve attached a photo of my setup.

Thanks everybody

kRz_4tw:
I´ve tried your Simple Stepper Code, it´s basically the same as the one I´ve been using so far though. It doesnt work either.

The programs have worked for others so I guess you have a connection problem or an inadequate power supply or a faulty A4988. The stepper drivers are easy to destroy if a wire between the driver and the motor becomes disconnected while the driver is powered.

I´ve attached a photo of my setup.

Photos of hardware are not reliable guides for wiring connections. Make a simple pencil drawing showing how everything is connected and post a photo of the drawing.

...R

I dont suspect a faulty A4988, I bought 5 at a time an none is working. Seems unlikely they are all broken.

Here´s a schematic I quickly drew up with fritzing.

kRz_4tw:
Here´s a schematic I quickly drew up with fritzing.

I deliberately suggested a pencil drawing because, as in this case, a Fritzing diagram is usually not at all clear.

...R

Here you go

Jesus, I got it. The documentation I was reading stated to connect one coil of the stepper to B1 and B2 and one to A1 and A1. Also on my ebay A4988 the pinout declation is swapped form 1A 1B… on the pololu units to B1, B2,… on my unit.

Running fine now after the coils are connected A1,B1 and A2,B2.

Thanks

On the Pololu A4988 web page the A4988 pins are labeled 1A and 1B for coil1 and 2A and 2B for coil2

...R