Adafruit HUZZAH 32 and NodeMCU - 32S

Dear community,

I am new in this forum so I hope I am not in the wrong discussion group.

I just started some MOOC about Arduino and to achieve my projects, I am using 2 different ESP32. One is NodeMCU-ESP32s and the other one is Adafruit HUZZAH32.

I followed the process explained on the different session by installing the software, in the URL adding "" and also download in the tools the ESP32 library from espressif system (version 1.0.2).

The issue I am facing now is that in the port for both devices, I have no USBtoUART appearing as it should. So I can not upload my program in the ESP32.

I tried all the card type: ESP32 Dev module, NodeMCU-32S and Adafruit ESP32 feather.

I have searched a long time on internet, installing some espressif packages, installing some CP2102, CP2104 VCP driver from Silabs and other website.
I rebooted computer, uninstall and reinstall,...

I almost tried everything without success :sob: :sob:

Does anyone faced the same issue ? if yes, how did you solve this issue ?

I am working on a MacBook Pro Mojave (10.14.3)

Thanks all in advance for your help and support,

thank you,


Make sure the USB cable is fully inserted into the USB jack on the board and computer.

You might have a damaged, defective, or charge-only USB cable. Try using a different cable.

Dear Pert,

Thank you for your reply.
I already tried several cables without success, but I will continue.