Adafruit micro-Sd breakout not initializing with MEGA 2650

Micro-SD breakout] [Connection to MEGAI am having quite a bit of trouble trying to get my Arduino MEGA 2560 to read my micro-SD card. My wiring is as follows:

Breakout Arduino
5v 5v
Gnd Gnd
CLK 52
DO 50
DI 51
CS 53
CD Was not connected and then connected to 47 (neither worked)
Here is my code:

[#include <Wire.h> //library nessesary to use I2C communications bus
#include <Adafruit_Sensor.h>
#include <Adafruit_BME680.h>
#include <SD.h>
#include <SPI.h>

const uint8_t chipSelect = 53; //chipSelect pin for the SD card Reader
const uint8_t cardDetect = 47;

File CO2Data; //Data object you will write your sensor data to

void setup() {
Serial.begin(115200);//“begins” the serial monitor so you can print stuff out when connected to the computer (set baud rate to 115200)
Wire.begin ();//begins the I2C communications bus so it can talk to the K33

Serial.print(“Initializing SD car…”);
pinMode(53, OUTPUT);

if (!SD.begin(chipSelect)) {
Serial.println(“Card failed, or not present”);
// don’t do anything more:
while (1) ;
}
Serial.println(“card initialized.”);
File CO2data = SD.open(“datalog.txt”, FILE_WRITE);
if (! CO2data) {
Serial.println(“error opening datalog.txt”);
// Wait forever since we cant write data
while (1) ;
}}
]

The SD card is formatted to FAT32. The Cardinfo example sketch gives me:
Initializing SD card…Wiring is correct and a card is present.

Card type: SD1
Could not find FAT16/FAT32 partition.
Make sure you’ve formatted the card

Thank you for any help!