Adafruit Mini Thermal Drucker druckt nicht ordentlich

Guten Abend,

Projekt:
Ich möchte für ein Event ein Häuschen bauen, welches "Wahrsagungen" druckt. Da ist so ein kleiner Thermaldrucker ja theoretisch das Richtige für. Das Häuschen soll unabhänig und mobile sein. Also sollte er auch über eine Powerbank betreibbar sein. Der Thermaldrucker von Adafruit wird mit 5-9DCV und 1,4A betrieben.
Mit einer normalen Powerbank mit einem Ausgang von 5DCV und 2A sollte das kein Problem sein. Die Powerbank wollte ich mir erst holen, wenn der Testlauf sauber ist.

Problem:
Nun ist der Drucker da und angeschlossen an eine seperate Stromquelle mit 5DCV und 1A. Und an meinen Arduino UNO angeschlossen. So wie es in der Anleitung steht.

Dazu noch die Bibliothek zu runtergeladen und wollte den ersten Druck machen. Also Beispiele geöffnet und den Testdruck ausgewählt. Kurz über den Code gelesen und los.

So sieht mein Testdruck aus:

Ich habe das Gefühl, desto mehr ich versuche zu drucken, desto weniger oder schlimmer wird das Ergebnis.

Meine Versuche das Problem zu lösen:

  • Eigenen Code geschrieben
    Ein simples Hallo. Hat er gedruckt. Hab mich gefreut. Hab dann den Code nicht geändert nur die zu druckenden Worte. Macht er nicht. Auch wenn ich ihm befehle zu feeden tut er das nicht, erkennt aber den Code.
  • Baud-Rate geändert
    Auf dem mitgeschickten Testprint steht zwar 19200, aber selbst mit 9200 will es nicht.
  • neuen Drucker bestellt
    Meiner könnte ja kaputt oder beschädigt sein. Nope, fehlanzeige. Der Neue macht genau das selbe.
  • Andere Bibliotheksversionen versucht.
    Ändert sich nichts.
  • Anderen neuen Code geschrieben
    Will nicht.
  • Erneuten Testdruck
    Ergebnis wird immer miserabler.
    -Pins geändert
    Langsam verzweifel ich...
  • Die anderen Testprints ausprobiert.
    Von allem, was er drucken sollte, ist das einzige was klar raus kam UPC-A, also Hab ich die Stelle rauskopiert und versucht diese zu verwenden, wieder eine Sackgasse.
    -Stromquelle geändert.
    Vielleicht bringt das etwas. Eine Powerbank mit 26800mAh. Ausgabe sind 5DCV und 2A. Sollte also für ne Weile Strom geben, da ich es ja auch mobile möchte. Löst das Problem leider auch nicht.

Ich versuche nun ein neues Entwicklerboard zu bekommen, da vielleicht da der Fehler liegt. Dann wäre ich verwundert, da ich dieses Entwicklerboard erst 6 Monate in benutz habe.

Schluss

Ich verzweifel langsam, weil nicht funktioniert. Ich habe mal kurzzeitige Erfolge, wenn ich es schaffe, das er "hallo" druckt, aber das wird zu Nichten gemacht, weil er nichts anderes Ordentlich, sondern nur abgeschnitten druckt. Auch versuche ich Tipps von anderen, die mit dem Thermal Printer bereits Probleme hatten, aber wie man vielleicht mitbekommen hat, will es nicht funktionieren.
Mein eigentlicher Plan ist, das der UNO von einer SD-Karte über einen Randomiser kleine Wahrsagungen druckt. Aber irgendwie fällt das grad alles ins Wasser.
Und ja auch auf der Offiziellen Troubleshoot Seite hab ich schon alles ausprobiert...
Hoffe ihr könnt mir helfen.
Danke im Voraus.
(Und Sorry für die möglichen Grammatik und Rechtschreibfehler. Bin nur etwas Verzweifelt.)

Ich hätte gerne die dazugehörigen Links hinterlegt, darf ich als neuer Nutzer aber nicht.

Da fehlt wohl etwas Stromergiebigkeit Deiner Versorgung. Thermaldrucker heizen und brauchen deshalb auch ihren Nennstrom.

Gruß Tommy

Ich würde 2 Fehlerquellen benennen:
Spannungsversorgung unterdimensioniert und Papierqualität.
Grüße Uwe

Papier schließe ich aus, da ich die Rolle auf der selben Seite, die wurde extra empfohlen, gekauft habe.

Dann versuchs mal mit einem stärkeren Netzteil

ist gerade in arbeit