Addding Library in 17

Silly question,
but how do you add a library in version 17 as it is no longer a folder.
I want to add the WAV library for use with the Adafruit Audio Shield. Where do I put it?


see: Arduino Blog

Thanks - got it.

Worth pointing out for Mac users:
control click on the app and select Show Package Contents. They are under Resources > Java > hardware > libraries.

n00b, that's true for finding the included libraries, but that's not where new libraries should be installed. They go in the libraries/ sub-directory of your sketchbook. That way they stick around when you upgrade to the next version of Arduino.

hrm, hi...

I'm still having problems loading custom libraries. I'm working with arduino 17, using mac OS 10.5.8.

I created a Libraries (spelt like that) folder in the same folder where my arduino sketches are, and added the capacitance library in there but doesn't show up when I try to import it.

Has this happened to anyone else? The only thing I noticed is when I hit "show sketch folder" it doesn't go to the folder in my documents until I save it.

Any advice is greatly appreciated! I too want to use my wavesheild stuff and see if it works!

I believe it is where you are putting the Libraries folder that is the problem.
I think it goes under user/documents/Arduino/, but I'm not on my MAC right now.

I'm thinking it's something like that too.

I will move things around; I was also thinking of removing that folder period and starting from scratch to see if that helps.

I'll report back; thanks for the insight!

Remember when you move stuff you have to restart the Arduino App for it to see it in its new place.

Well, I made a new arduino folder (all my old sketches are on my usb key safely) and it does look like I have the Libraries folder working.

I used the CapacitiveSense library just to test and it was recognized. I noticed when I imported it though it didn't look like the other libraries, i.e.
#include <CapSense.h> looks like that, not like #include <CapSense.h> which I thought it would look like.

I'm guessing this still indicates a problem? Maybe I didn't extract the library properly or something?

Thanks for the guidance so far!

Each library is responsible for supplying a properly formatted file defining what keywords to highlight, and how. Perhaps the CapSense library is missing this file, or did not include CapSense in the file.

Look for a file called keywords.txt in the CapSense folder.

Heyyy, you're right, PaulS, no keywords.txt file there....

I'll try finding another copy. It looks like my library issue is solved for now.

Thanks everyone!

I'm having a frustrating problem with adding libraries to 0018. Just started working with this - have some background in both electronics and Basic/Pascal programming.

Been trying to add 'DateTime' library - comes back with the 'DateTime.h: No such file or directory etc...' So I tried another library as a test, 'Tone'. Also same results. Click on 'Sketch' --> 'Import Library' --> 'DateTime' (or 'Tone'), does nothing.
I understand to create a folder called 'Libraries' as a sub-folder where my own sketches are stored like this:
C:\Documents and Settings\Administrator\My Documents\Arduino\Libraries
then from there I now have two directories with all files DateTime and Arduino_Library_Tone.

Ardunio executable is all in the C:\Program Files\ardunio-0018
and the pre-installed libraries work fine like EEPROM (one that I have used recently)

I'm using Windows XP professional - Arduino works great I love it so far but I would like a simple clock solution for a couple of experiments (and aware of the RTC chip, just didn't want addtional hardware...)

Wonder if I should re-install or something...

I'm having a frustrating problem with adding libraries to 0018.

When you have started the Arduino for the first time it asked you to name the directory where your sketches are stored. This is usally refered to as the sketchbook-directory.
This is also the directory where you have to install the libraries.

So wherever your sketchbook is, create a folder libraries this diectroy and install your additional libarries into this directory.

This is about the same information already available in this thread:

In addition, you do need to restart the IDE for it to find them.

Also, the DateTime library has been replaced with an updated version named Time that offers a superset of the DateTime capabilities, see: Arduino Playground - Time

Maybe this is where the hic-cup is. Starting, I mean initially downloading --> then unzipping. No self extracting/install program, I just plopped the entire arduino-0018 files and executable into C:\Program Files\

I could be wrong here but I don't remember getting any prompts for sketchbook locations or anything. I just made a shortcut to the arduino.exe that is on my desktop. I dunno, I'll keep trying this, it's just weird.

I think I will load a new instance on another machine (never had arduino loaded) it's got to be something simple... Thanks everyone for your help.

Does the same thing on an entirely new machine, running Vista Home professional on that one. Downloaded (from --> extracted just to the desktop --

found and double-clicked on ardunio.exe --> simply runs the environment (new sketch at top, today 'sketch_mar31a'). Doesn't ask anything.
It does make a directory for sketches (in this case C:\User\Desktop\Arduino) --> Then I create a sub-folder called libraries --> added DateTiime there --> Closed and re-ran arduino IDE --> Shows up on 'Sketch' --> 'Import Library' --> Click on DateTime (at the bottom, below all core libraries).
It just adds like a carriage return in the environment and thats it, like it doens'nt see it... There's something glitchy here...

Then I create a sub-folder called libraries --> added DateTiime there

The zip should be extracted in the libraries directory so it creates a subdirectory below Libraries named DateTime that contains DateTime.h, DateTime.cpp keywords.txt and an examples directory.

Do you have those files in that directory structure?

I just tried it again same results. Ran extraction wizard - directly extracted and made this folder.

C:\Documents and Settings\Administrator\My Documents\Arduino\Libraries\DateTime

I created the folder called 'Libaries' then placed the in that folder. Then extracted which created a sub-folder called DateTime

Now for the files: (I would upload small .jpg if I could here, haven't figured that one out yet)

C:\Documents and Settings\Administrator\My Documents\Arduino\Libraries\DateTime
files in this folder are readme.txt

Two sub-folders called DateTime , DateTimeStrings

C:\Documents and Settings\Administrator\My Documents\Arduino\Libraries\DateTime\DateTime

Files in this folder are: DateTime.cpp , DateTime.h , keywords.txt

C:\Documents and Settings\Administrator\My Documents\Arduino\Libraries\DateTime\DateTime\Examples\DateTime

C:\Documents and Settings\Administrator\My Documents\Arduino\Libraries\DateTime\DateTime\Examples\Processing\

One file in this folder: SetArduinoClock.pde

C:\Documents and Settings\Administrator\My Documents\Arduino\Libraries\DateTime\DateTimeStrings

three files here: DateTimeStrings.cpp , DateTimeStrings.h , keywords.txt

And again my preferences within the arduino IDE are:
(By clicking 'File' --> 'Preferences' --> Sketchbook location:

C:\Documents and Settings\Administrator\My Documents\Arduino

Everything else is running fine, I have faded LED's, currently logging temperatures with an LM34DZ (using alternate millis() code for time)
I have about 13 sketches and then this folder called Libraries, but cannot "#include <DateTime.h>" in a sketch.

C:\Documents and Settings\Administrator\My Documents\Arduino\Libraries\DateTime\DateTime
Files in this folder are: DateTime.cpp , DateTime.h , keywords.txt

you should have:
C:\Documents and Settings\Administrator\My Documents\Arduino\Libraries\DateTime
Files in this folder should be: DateTime.cpp , DateTime.h , keywords.txt

move the files up one subdirectory and try that

Also, once you have verified that works, download and try the Time library which replaces the now obsolete DateTime library