Added Attiny to 1.6.5 now nothing compiles.

Last weekend I upgraded to 1.5.6 on Xubuntu. I tested 2 sketches, verified, uploaded, and ran. Today, I added the Attiny libraries and everything broke! (Worked fine on 1.0.5)

Arduino: 1.6.5 (Linux), Board: "Arduino/Genuino Uno"
...edited to fit, but all seemed OK until this point...
/sketch_nov07a.cpp.elf /tmp/build7945201259575196130.tmp/sketch_nov07a.cpp.o /tmp/build7945201259575196130.tmp/core.a -L/tmp/build7945201259575196130.tmp -lm 
avr-gcc: error: /tmp/build7945201259575196130.tmp/core.a: No such file or directory
Error compiling.

core.a can’t be found?

Searching took me to a PCREL error, and I don’t see that problem.

Thoughts?

-fab

Note: you say 1.5.6 but actually meant 1.6.5. What did you do to add the "Attiny libraries", where did you get the "Attiny libraries"?

Yes, 1.6.5...oops.

I used the Mellis link (ATtiny44/45/84/85 Recommended' ) from the playground, and instructions from highlowtech.org via the link in preferences and then loaded with boards manager.

So far, I have of course, removed the Attiny cores. Installed avr-gcc completely according to LadyAda. Tried to reload an older arduino IDE without joy...just stayed at 1.6.5 Shutoff all preferences that were turned on before attempting to verify code today.

And hours later, I still have the same error!

Very frustrating indeed!

I've considered installing the not ready for prime time 1.6.6, even downloaded it, but too chicken! I have enough troubles already!!

-fab

Strange because that shouldn't alter any of your Arduino install files, it only adds the attiny files so once you have removed them from the arduino15 folder you should right back where you were before. I've installed that attiny using the same Boards Manager method with 1.6.5 multiple times(I'm actually the person who added that feature to attiny) and it never caused a problem, I just did it again and still no problem. I'd completely uninstall the Arduino IDE and also back up then delete the ~/.arduino15 folder(you could save your preference.txt file from it if you don't want to reset all your preferences) then reinstall. Let me know if that helps.

OK pert, I'll try that tomorrow.

While working on the issue, I decided to decompress 1.6.6 and run it. It works just fine. I might just be chasing a corrupted file, and the remove and reinstall will likely take care of the problem. It could just be a coincidence that it happened after loading the Attiny cores.

Thanks!

Cheers!

-fab

Well there you go, just use 1.6.6 unless you run into some bug that forces you back to 1.6.5. I've been using 1.6.6 for months and it's great. If you find a bug it just gives you an opportunity to contribute to Arduino by reporting it. If more people had been testing the hourly build then their bugs would have been fixed before the release.

pert: Well there you go, just use 1.6.6 unless you run into some bug that forces you back to 1.6.5. I've been using 1.6.6 for months and it's great. If you find a bug it just gives you an opportunity to contribute to Arduino by reporting it. If more people had been testing the hourly build then their bugs would have been fixed before the release.

pert, I'm still using 1.6.5. Are there any great advantages to switching to 1.6.6, if I'm having no problems with 1.6.5?

And back on-topic, I too installed the ATtiny stuff a few weeks ago, on 1.6.5 and using the same methods, and had no problems at all. (Thanks pert, for your efforts. Karma added, FWIW)

The biggest change is a completely new preprocessor, arduino-builder, that fixes a lot of the failings of the old preprocessor in automatic function prototype generation and improves compile speed as well as can be used from the command line. As with any big change it has also added a few bugs:

There has been a ton of work on the pluggable USB and HID features.

Serial Plotter

Library Manager and Boards Manager notifications when there is an updated version of any installed library/board.

There are lots of improvements to the libraries, especially Ethernet and Servo. You can update these in 1.6.5 with Library Manager also of course.

There's lots more I'm not remembering because I've been just installing the hourly builds a few times a week so they have come gradually over the last 4 months. Just a ton of work done, many small bugs fixed. It's great to see such active development on the IDE, for a while there things were moving very slowly. I actually thing we have .org to thank for giving .cc a kick in the pants although, as with most kicks in the pants, it wasn't very kindly done.

They could have waited a bit longer before releasing 1.6.6 but that's the decision of the developers. I think there's a huge problem of many of the experienced users never wanting to update because of bugs, but that just causes the bugs to not be reported and thus not to be fixed so it's a vicious cycle. A lot of people are still on v1.0.5! The developers are really good now about getting on things once they are reported, often the fix is done in less than a day.

Glad to hear ATtiny is working well for you and thanks for the karma! I really like that Boards Manager makes it easy for anyone to add new hardware to Arduino and keep it updated. I've been working to add support for it to all my favorite projects.

This morning I deleted the 1.6.5r5 directory and extracted the tarball again, no change. When I tried to verify the minimum sketch and then blink, same error.

I deleted the newly extracted directory and the tarball, downloaded a fresh tarball, and tried again...no change.

I noticed there is a .arduino15 folder in my home directory, which I did not delete since there is no problem with 1.6.6, and no .arduino16 folder.

When I installed 1.6.5, I used the install.sh. 1.6.6 I had been just running from the folder, so I then made the install.sh executable and ran it. It put up the icon, I renamed it, and all is still well with 1.6.6.

What I would like to know is why is there a .arduino15 folder, but no 16 folder, and can I delete it?

It was surprising to me that this is all about a problem getting the IDE to work and the thread was moved to microcontrollers? Seems misplaced?

Also, I will try to do the attiny addition again. Scary though because 1.6.6 is working now, and I have not been able to repair 1.6.5!

-fab

The .arduino15 folder is used for 1.6.5 and 1.6.6. That's where your preferences.txt file is located and where the hardware files are installed to when you do updates with Boards Manager. The reason these files are put in that folder instead of the arduino15 folder is so that when you update the IDE to a new version you won't have to reset your preferences and reinstall all the boards you installed with Boards Manager. So the only permanent loss you can suffer from deleting it is that you will have to reset your preferences as all the boards in that folder should be easy to reinstall using Boards Manager. There is a good chance your error is caused by something being wrong with files in that folder(for example: .arduino15/packages/arduino/hardware/avr/1.6.9/platform.txt). So I recommend you back up the .arduino15 folder by renaming it, then reload 1.6.5. On my system(Windows 7) I don't need to reinstall the IDE after doing this. Just reopening the IDE automatically creates the arduino15 folder and the files inside of it. If you don't want to lose all your preferences then you can copy the preferences.txt file from your old arduino15 folder to the new one. Then open Tools > Board > Board Manager... and update your boards files again to the most recent version.

The reason for the name is that there are 2 branches of Arduino, 1.0.x and 1.5+ at the time that folder was created I think the 1.5+ branch of the IDE was still in the 1.5.x version range.

I think the reason it was moved is because of the ATtiny title though I agree it is more closely related to the IDE than to microcontrollers but the forum admins are too busy to read every post so it makes sense.

Thanks for the hand holding pert!

Funny the 1.6.6 is working with that same directory, but 1.6.5 still does not, even after removing board definitions for the Attinys. That is confusing to say the least...

I'll try the preferences & BM update again...with crossed fingers!!

-fab

Added the board definitions to 1.6.6 and it seems to work fine.

Thanks for all the help folks!

-fab

Great news! Is that with attiny installed via Boards Manager also?

Yes, same links same method, same .arduino15.

I have NO IDEA what was wrong, or why 1.6.5 still won't work, but I am moving on with life. 1.6.5 is relegated to the ether...

Thanks Again! -fab

Glad I could help. I wish we could have found the source of the problem as it concerns me that installing attiny via Boards Manager might cause problem for non-attiny boards. After all Boards Manager is supposed to make things easier, not more difficult. Well hopefully it was only a fluke and I'm glad you're back up and running with the latest and greatest!

I think I found the cause of the

avr-gcc: error: /tmp/build7945201259575196130.tmp/core.a: No such file or directory
Error compiling.

Error in Arduino IDE 1.6.5. If you update Arduino AVR Boards to 1.6.9 in Boards Manager it contains a recipe that is incompatible with any IDE version previous to 1.6.6. You can fix this issue by:

  • Tools > Board > Boards Manager...
  • Wait for downloads to finish.
  • Click on Arduino AVR Boards
  • Select Version 1.6.8
  • Click Install

yes pert, I think that would've fixed it! I did notice that AVR Boards was at 1.6.9. But I am still working great with IDE 1.6.6, so I just moved on. It is VERY likely that if I saw an update to Boards, I would've installed it as I was in process of playing with the new toolset in 1.6.5.

For giggles I recompiled an older project on and found it 90 bytes bigger in 1.6.6, but haven't determined why yet. I spent quite some time figuring out how to get the .lss listing file going, and now that it works, I have not wanted to determine the cause of the inflation. It is due for a major rewrite, and I am really procrastinating on that as I had some really bad experiences with it while originally trying to get it to run. As it turned out, my problem (that took a year to find) was that I was developing on one PC, and moving the code to a laptop. I had forgotten that I enlarged a parameter in a library during development, and never modified the library on the laptop. Drove me nuts a full year before the AH-HA moment. So that was about a year ago, and i am still gun shy!

Anyway, I really appreciate your interest and skill in finding the problem. I was quite leary of going to 1.6.6, but it has been painless thus far.

Happy Coding! -fab