ADS1115 stopped working

I've been trying to set up an ADS1115 to measure a voltage. It was working fine until I tried to change the address of it, then it went strange, giving me garbage on the serial console.

I set it back to what it was, reflashed the micro and it went back to normal, except that it isn't detecting any voltages.
I am guessing that I've killed the chip, except that it still responds to the I2C.
Any ideas of how to test it before I bin it, and any guesses as to what might have happened to kill it?

Sure, connect the module in the simplest configuration possible, run the simplest read example sketch from the ADS1115 library you're using, and connect it to a known good voltage reference.

1 Like

I think the example sketches are much of a muchess for simplicity and I had tried one, but another one with a different mode seems to have shaken out of its trouble.

Unfortunately, having got it working, I decided to connect it up, got it wrong and it caught fire...

Ah well. Never mind.

Sounds like there were a few moments of excitement!

1 Like

"What's that smell?", I said, "Oh ************!"
Luckily it was just waving in the air on the end of its wire, so it only set itself on fire, and they don't burn very well...