After Uploading sketch, arduino doesnt respond

I just got my arduino duemilanove yesterday. I was doing some simple sketches/circuits with reading values from a photoresistor thru a voltage divider, connected to pin 0 on the arduino. I changed some code in the arduino IDE and uploaded, after the reset, the board is unresponsive. When i try to upload a sketch, the rx light blinks a couple of times rapidly, then the onboard LED (pin 13) flashes rapidly. Communication times out shortly thereafter. Looking at the schematics for the duemilanove, i see that pin 0 and 1 are rx/tx for serial comms that are routed to the respective pins on the FTDI chip. My question is, is having a variable input (photoresistor, pot, etc..) connected to pin 0/1 dangerous when uploading sketches? Seems to me that this could corrupt serial data coming in / going out from the IDE. Secondly, is this the reason that my arduino is now "dead", and is it possible that its just that the bootloader is corrupted and would need to be reprogrammed? I appreciate any help you can give to a brand new arduino enthusiast. By the way, i am using windows, and the FTDI chip shows up in the device manager, and i have tried it on another WinXP machine as well as my macintosh desktop, i get the same result on all of them. I have also tried hitting the reset at different points before/after hitting upload to I/O Board in the IDE, i get the same result (figured if i had corrupted code, i could reset and let the IDE catch the board before it entered the corrupted code, not that lucky i guess.)

Remove your wiring from pin 0 and 1, then try and upload and run one of the standard examples like blink and see if it works. It's generally not adviced to use pins 0 and 1 with external components unless you factor in their effect on the serial communications.

Lefty

That was the first thing i tried. When i noticed the board was unresponsive, i disconnected all inputs/outputs leaving only the USB cable to the computer. When i have the board powered on, and attempt to send a sketch ( i tried blink, and a couple others) i get the behavior i listed of blinking the rx led a few times, then the pulsing of pin 13 (for around 20 secs, then i have no led's lit/blinking, save the the steady on power led.)

Does the Arduino IDE software now give you an error when you upload a sketch?

Lefty

yes, it does.

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I just re-connected it, and here is the exact sequence of events.

  1. I plug in the usb cable, the tx/rx light flash momentarily (initialization of the usb chip?)
  2. pin 13 pulses rapidly, indefinitely until i interrupt it to attempt to upload a sketch.
  3. I attempt to upload say, digital>Blink. The board resets, and i get a momantary pulse of rx/tx then pin 13 pulses rapidly once more. it seems after the first upload attempt, it times out and pin 13 stops pulsing.

That is the usual error codes when the IDE can't 'talk' to the Arduino board. One quick test you can do is to prove out the communications link separate from the board's processor/bootloader.

Remove the processor chip from it's socket. Wire a jumper from pin 0 to pin 1. Plug the board into the PC usb. Listen to see if the PC 'sees' the new USB connection. Launch the Arduiono IDE and select the proper comm port. Now click on the serial monitor. Anything you type and send from the serial monitor's send window should be echoed back in it's receive window.

If that works, then most likely there is a problem with the processor chip and it would be best to buy a new one that has a bootloader already installed in it. Like this one: http://www.sparkfun.com/commerce/product_info.php?products_id=9217

Good luck

Lefty

So i tried removing the uC and i connected a jumper to pins 0 and 1 and opened the serial monitor. When i send data, i get a flash of the RX led, no flash of the TX led and no data echoed back to the serial monitor. So, it looks like the serial chip is damaged somehow. Bummer.. Hopefully the uC is still ok. I'll put it on a breadboard and see if the chip is still alive and get another board. It must have been something i have done, so its a learning experience i guess. a $30 learning experience! :-? Thanks alot for the advice, and for the serial monitor trick, i'll definitely store that for future reference.

i have the excactly same problem. i bought a new chip and it works perfect but im back to debugging the fried chip. i have runned it through avr studio with the avr isp mk2 burner and i can talk to it and burn programs and stuff but still it seems like it stuck blinking that led.

the arduino ide does not work when i try burning a new bootloader, so i did it in avr studio instead. i get all ok when burning but its still stuck...

No wait! it just came back alive! :) it worked burning the arduino 168-328 bootloader on the stuck atmega328 using avr studio. i found the library in the arduino/hardware/arduino/bootloaders folder somewhere btw.

Still a bit weird that a buggy code can stall the bootloader on the atmega completely

I have the same problem.

My Arduino still work the last sketh loaded, but when I try to load a new sketch, the Rx led of the FTDI shines in green and Arduino IDE says "Uploading to I/O board".

How can to solve this with AVR Studio?