[Aide] Vérification d'un montage

Coucou, Je suis en train de réaliser un contrôleur MIDI avec un Arduino UNO. Pour l'instant il ressemble à ça:

(Il est déjà tellement beau actuellement que les rageux diront photoshop)

Mais ce n'est pas la question là, enfaîte je ne suis pas convaincu de mon montage à 100%. Parce que je l'ai récupéré sur un tutoriel et que je l'ai ensuite modifié. Le montage en question:

Est-ce qu'il y a un soucis ? Merci de me répondre :) Cordialement.

L'idéal serait de rajouter une prise Din 5 broches femelle pour brancher ensuite le Midi directement.

Bonjour !

Le montage est tiré de ce tutoriel:

En relisant le tutoriel pour l’histoire de la résistance pull-down je crois que c’est uniquement pour le pin 13 que c’est indispensable.
Même si je ne comprends pas trop la raison je vais l’enlever parce que là c’est le pin 9.
Donc je dois suivre ce montage:

Et pour répondre à Christian, tu as raison mais normalement l’usb fera très bien l’affaire.

En relisant le tutoriel pour l'histoire de la résistance pull-down je crois que c'est uniquement pour le pin 13 que c'est indispensable.

[u]Coté micro[/u] il n'y a pas de pin différentes donc pas plus d'obligations sur la 9 que sur la 13 ou n'importe qu'elle autres.

[u]Coté carte :[/u] eh bien c'est simple il circule beaucoup de versions différentes, la del est soit connectée directement sur la pin 13 et reliée à la masse au travers d'une résistance, soit connectée en sortie d'un ampli op et c'est l'entrée à haute impédance, donc qui fait office d'isolateur, de l'ampli op qui est relié à la pin 13. Effectivement dans le premier cas il faut placer la résistance de pull machin de tirage à la masse alors que dans le deuxième cas on peut la placer soit à la masse, soit à l'alim, soit utiliser celle interne au micro.

[u]Il ne faut pas croire ce qui est écrit sans vérifier[/u] surtout quand cela provient du site www.instructables.com qui est connu pour ses approximations et ses erreurs.

Bonsoir, "eh bien c'est simple il circule beaucoup de versions différentes" Mais du coup comment je peux savoir quelle est la "version" ? Est-ce que dans ce cas je dois en mettre une ou pas alors ?

Merci de m'aider :)

Je n'ai pas tout compris, vous parlez de quelle led ? Sur mon schéma il y a seulement des boutons, aucune led. Je n'ai donc pas besoin d'une résistance pour mon montage actuellement ?

Bonjour,
Il y a confusion parce que dans ton premier schéma tu insères une résistance sur la pin 13 en commentaire, alors que le fil mène à la pin 9.
La pin 13 est normalement reliée à une led existante sur la carte, mais on peut quand même la configurer en entrée.

Il faut enlever le fil 5 v de ton deuxième schéma, sinon c’est le court-circuit de l’alimentation. et câbler le dernier bouton comme tous les autres.

Utiliser les résistances de tirage internes au µp par pinMode(unBouton, INPUT_PULLUP)

Les concepteurs de la carte ont placé une del et même si tu ne t'en sert pas elle est bien présente et sa présence n'est pas sans conséquences.

C'est à cause de sa présence et de sa connection vers la masse que selon la version de la carte tu peux, ou ne peut pas utiliser une résistance de tirage à l'alimentation (pull up) .

Les schémas des cartes arduino sont librement disponibles.

PS : Pour être associées à des boutons les résistances internes au micro sont suffisantes mais il faut bien garder en tête que leur précision de fabrication n'est que de +/- 30% !

Sur la carte uno r3, la led est astucieusement pilotée par un ampli op dont l'entrée + est sur la broche 13, ce qui fait que lorsque cette broche est utilisée en entrée, elle n'est pas du tout perturbée et on peut utiliser le pullup interne sans problème. Maintenant je ne sais pas si c'est le cas sur toutes les cartes compatibles.

Merci de m'aider, c'est super cool !

"Il y a confusion parce que dans ton premier schéma tu insères une résistance sur la pin 13 en commentaire, alors que le fil mène à la pin 9." Exact, tu as raison.

Donc mon montage doit ressembler à ça au final ? http://image.noelshack.com/fichiers/2015/35/1440938254-1440847099-montage.png

Mais du coup je me demande comment c'est possible que le montage du tutoriel Instructables puisse fonctionner avec autant d'erreurs ?

Mais du coup je me demande comment c'est possible que le montage du tutoriel Instructables puisse fonctionner avec autant d'erreurs ?

Je réécrit :

Il ne faut pas croire ce qui est écrit sans vérifier surtout quand cela provient du site www.instructables.com qui est connu pour ses approximations et ses erreurs.

Ils écrivent au km et ne vérifient pas systématiquement ce qu'ils écrivent. Dans leur production il y a du bon, des fois du très bon, mais il peut aussi y avoir des conner*ies à ramasser à la pelle. Et comme ils écrivent à la façon de ceux qui sont sûr d'eux les débutants peuvent tomber dans des galères pas possibles.

Kubert: Donc mon montage doit ressembler à ça au final ? http://image.noelshack.com/fichiers/2015/35/1440938254-1440847099-montage.png

Mais du coup je me demande comment c'est possible que le montage du tutoriel Instructables puisse fonctionner avec autant d'erreurs ?

Je viens de voir le tuto en question.

Ils utilisent 12 boutons et je ne vois pas d'erreur instructables.com/id/Arcade-Button-MIDI-Controller/step5/Wiring/

Je n'ai pas été assez méchant pour dire qu'il y avait toujours des erreurs. Ce n'est pas un site que j'examine à la loupe mais sur le forum anglais a de nombreuses reprise j'ai pu lire des commentaires signalant des erreurs.

Par contre je persiste à dire qu'il ne faut jamais prendre pour argent comptant ce qu'on peut lire sur internet, il faut au moins comparer plusieurs sources d'information, ne jamais se contenter d'une seule.